Bug 15525 - (gem_madvise_ioctl) Blank screen after some time, after hibernation/suspend
(gem_madvise_ioctl)
Blank screen after some time, after hibernation/suspend
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-03-12 17:24 UTC by capsel
Modified: 2010-07-24 22:50 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33
Tree: Mainline
Regression: Yes


Attachments

Description capsel 2010-03-12 17:24:28 UTC
Screens goes black (or almost black... grey?), somtimes I could see some random color bars across screen. I'm not certain about conditions as it happened after several hibernations and suspends, after about 2 hours of normal work.

After a blank-out I can switch from X (alt+ctrl+f1) and press alt+ctrl+delete to restart, but screen is still blank. Pressing alt+ctrl+f7 (to X) does not help.

The only error is in /var/log/messages:
kernel: [drm:i915_gem_madvise_ioctl] *ERROR* Attempted i915_gem_madvise_ioctl() on a pinned object

I wanted to try new kernel on msi wind u100 as 2.6.32 series gave almost instant blank-outs (black, pink...).

I'm using gentoo, and it's kernel 2.6.31-gentoo-r10, and it works fine.
Comment 1 Rafael J. Wysocki 2010-03-15 21:33:03 UTC
2.6.34-rc1 works fine with the KMS driver on my Wind U100.  Can you try this one, please?
Comment 2 capsel 2010-03-15 23:18:44 UTC
I did not hibernate or suspend and screen didn't have any unusual colors but...
After 2 hours since boot screen froze. Everything was still but mouse cursor, which changed it appearance (arrow, text, resizing) according to what was on screen. So I killed X.

from syslog:
kernel: [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
kernel: render error detected, EIR: 0x00000000
kernel: [drm:i915_do_wait_request] *ERROR* i915_do_wait_request returns -5 (awaiting 980788 at 980776)

and that was 2.6.34-rc1
Comment 3 capsel 2010-03-15 23:30:54 UTC
I forgot to mention that I could switch from text console (with KMS) to X and back. Screen in X was frozen - nothing changed - but console was working.

And 1 hour not 2.

...that's kind of progress, isn't it?
Comment 4 Rafael J. Wysocki 2010-03-21 19:35:01 UTC
What version of the user space Intel driver do you use?
Comment 5 capsel 2010-03-22 00:07:37 UTC
from emerge -s intel:

*  x11-drivers/xf86-video-intel
      Latest version available: 2.9.1
      Latest version installed: 2.9.1
      Size of files: 770 kB
      Homepage:      http://xorg.freedesktop.org/
      Description:   X.Org driver for Intel cards
      License:       MIT

any other info I can give to help?
Comment 6 capsel 2010-03-31 16:45:13 UTC
Just few seconds ago, under 2.6.34-rc2, screen started flickering. I'm running kde-4.4.1, on one (virtual) desktop rsync, on other www browser. There are no messages in dmesg or Xorg.0.log about this. After switching desktops for a while the effect disappeard.
Comment 7 capsel 2010-04-04 13:57:39 UTC
2.6.33.2 works somewhat better. Sometimes screen becomes black for a moment (less than second) or mouse cursor looks like few bitmap lines switched their places. But now under xfce/compiz.
Comment 8 capsel 2010-04-09 09:45:52 UTC
This bug is still valid. What info should I give?
Comment 9 Rafael J. Wysocki 2010-04-10 19:15:43 UTC
On Saturday 10 April 2010, Kacper Kopczyński wrote:
> Dnia 2010-04-09, o godz. 01:04:34
> "Rafael J. Wysocki" <rjw@sisk.pl> napisał(a):
> 
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.32 and 2.6.33.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.32 and 2.6.33.  Please verify if it still
> > should be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15525
> > Subject		: Blank screen after some time, after
> > hibernation/suspend Submitter	:  <capsel@matrix.inten.pl>
> > Date		: 2010-03-12 17:24 (28 days old)
> > 
> > 
> 
> It still does not work as I described on "Bug-Entry".
Comment 10 capsel 2010-04-11 13:38:04 UTC
To be more precise - every 2.6.32.(-10) and 2.6.33.* and 2.6.34-rc{123} does not work well. This is a regression but from 2.6.31 series.

Some time ago gentoo unmasked 2.6.32 series kernel, but it does not work - same symptoms, even without hibernation/suspend.

How can I help, can someone direct me?
Comment 11 capsel 2010-04-20 10:28:49 UTC
I'm testing gentoo-sources-2.6.33-r1, which seems to include 2.6.33.2 patches, and user space driver 2.11.0 for over a week, and all seems to work well.
Comment 12 capsel 2010-04-21 18:41:06 UTC
...and screen went black. kernel 2.6.33.2 ("vanilla"), driver 2.11.0. No messages in /var/log/messages od /var/log/Xorg.0.log.
Comment 13 capsel 2010-05-26 10:27:29 UTC
Now I'm using kernel 2.6.34 and driver 2.11.0 since it (kernel) was released and it works well
Comment 14 Chris Wilson 2010-07-24 09:26:35 UTC
Yes, you hit both a userspace bug which was attempting to re-use pinned (since they were being used for scanout) buffers. As noted, fixed in xf86-video-intel-2.11.0

Note You need to log in before you can comment on or make changes to this bug.