Bug 15504 - BUG: key ffff88004c3811e0 not in .data! occured in lockdep.c
BUG: key ffff88004c3811e0 not in .data! occured in lockdep.c
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: Other
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: other_other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-03-10 06:56 UTC by Christian Casteyde
Modified: 2010-09-23 05:27 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.34-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Christian Casteyde 2010-03-10 06:56:16 UTC
Acer Aspire 1511LMi
Athlon 64 3000 in 64bits mode
1.2 GB RAM
Bluewhite64 13 (32 bits version of Slackware)
Kernel 2.6.34-rc1

Since 2.6.34-rc1, I get the following warning when the kernel is compiled with hacking options (lockdep validation, map checks, etc.):

...
input: Power Button as /class/input/input3
ACPI: Power Button [PWRF]
Marking TSC unstable due to TSC halts in idle
Switching to clocksource acpi_pm
BUG: key ffff88004c3811e0 not in .data!
------------[ cut here ]------------
WARNING: at kernel/lockdep.c:2706 lockdep_init_map+0x554/0x600()
Hardware name: Aspire 1510
Modules linked in:
Pid: 1, comm: swapper Not tainted 2.6.34-rc1 #3
Call Trace:
 [<ffffffff8105d6f4>] ? lockdep_init_map+0x554/0x600
 [<ffffffff810347e8>] warn_slowpath_common+0x78/0xd0
 [<ffffffff81000190>] ? do_one_initcall+0x0/0x190
 [<ffffffff8103484f>] warn_slowpath_null+0xf/0x20
 [<ffffffff8105d6f4>] lockdep_init_map+0x554/0x600
 [<ffffffff815a1c99>] ? error_exit+0x29/0xb0
 [<ffffffff8110e72c>] sysfs_add_file_mode+0x6c/0xd0
 [<ffffffff8110e79c>] sysfs_add_file+0xc/0x10
 [<ffffffff8110e861>] sysfs_create_file+0x21/0x40
 [<ffffffff812d71a4>] device_create_file+0x14/0x20
 [<ffffffff813cc907>] thermal_zone_bind_cooling_device+0x1a7/0x290
 [<ffffffff81297854>] acpi_thermal_cooling_device_cb+0x85/0x17b
 [<ffffffff813cc760>] ? thermal_zone_bind_cooling_device+0x0/0x290
 [<ffffffff8129796c>] acpi_thermal_bind_cooling_device+0x10/0x12
 [<ffffffff813cc4ec>] thermal_zone_device_register+0x30c/0x470
 [<ffffffff81297b71>] acpi_thermal_add+0x203/0x487
 [<ffffffff812721f2>] acpi_device_probe+0x53/0x11e
 [<ffffffff812d9eab>] driver_probe_device+0xab/0x1c0
 [<ffffffff812da053>] __driver_attach+0x93/0xa0
 [<ffffffff812d9fc0>] ? __driver_attach+0x0/0xa0
 [<ffffffff812d958b>] bus_for_each_dev+0x6b/0xa0
 [<ffffffff812d9cec>] driver_attach+0x1c/0x20
 [<ffffffff812d8c9c>] bus_add_driver+0xbc/0x270
 [<ffffffff81ab9145>] ? acpi_thermal_init+0x0/0x7b
 [<ffffffff812da36c>] driver_register+0x7c/0x160
 [<ffffffff81ab9145>] ? acpi_thermal_init+0x0/0x7b
 [<ffffffff8127388c>] acpi_bus_register_driver+0x3e/0x42
 [<ffffffff81ab919e>] acpi_thermal_init+0x59/0x7b
 [<ffffffff810001c7>] do_one_initcall+0x37/0x190
 [<ffffffff81a9e5bd>] kernel_init+0xe0/0x16c
 [<ffffffff815a0882>] ? trace_hardirqs_on_thunk+0x3a/0x3f
 [<ffffffff81003074>] kernel_thread_helper+0x4/0x10
 [<ffffffff815a183e>] ? restore_args+0x0/0x30
 [<ffffffff81a9e4dd>] ? kernel_init+0x0/0x16c
 [<ffffffff81003070>] ? kernel_thread_helper+0x0/0x10
---[ end trace 93d72a36b9146f22 ]---
thermal LNXTHERM:01: registered as thermal_zone0
ACPI: Thermal Zone [THRM] (50 C)
ACPI: Battery Slot [BAT1] (battery present)
lp: driver loaded but no devices found
Non-volatile memory driver v1.3
...
Comment 1 Christian Casteyde 2010-03-22 18:35:54 UTC
Update : still present in 2.6.34-rc2.
Comment 2 Christian Casteyde 2010-03-31 20:15:09 UTC
Seems to be fixed with this patch when applied to -rc3:

From Dan:

We now have to call sysfs_attr_init() for dynamically allocated sysfs 
attributes or lockdep complains.

Signed-off-by: Dan Carpenter <error27@gmail.com>

diff --git a/drivers/thermal/thermal_sys.c b/drivers/thermal/thermal_sys.c
index 5066de5..d4fec47 100644
--- a/drivers/thermal/thermal_sys.c
+++ b/drivers/thermal/thermal_sys.c
@@ -725,6 +725,7 @@ int thermal_zone_bind_cooling_device(struct thermal_zone_device *tz,
                goto release_idr;
 
        sprintf(dev->attr_name, "cdev%d_trip_point", dev->id);
+       sysfs_attr_init(&dev->attr.attr);
        dev->attr.attr.name = dev->attr_name;
        dev->attr.attr.mode = 0444;
        dev->attr.show = thermal_cooling_device_trip_point_show;
Comment 3 Wolfram Sang 2010-04-01 01:51:58 UTC
Duplicate of Bug 15548. Proposed patch from there looks a bit different
(https://patchwork.kernel.org/patch/87436/).
Comment 4 Christian Casteyde 2010-04-13 21:54:33 UTC
Update: doesn't seem to occur anymore in -rc4.
Comment 5 Christian Casteyde 2010-04-20 19:05:32 UTC
Closing since it doesn't occur either in -rc5 => patch may be upstream now...
Comment 6 Wolfram Sang 2010-04-21 00:08:58 UTC
Fixed by 975f8c5653acba461229e671202113da69b87be1 (as the duplicate bug 15548).
Comment 7 Wolfram Sang 2010-09-22 21:40:43 UTC
Who is closing this?

Note You need to log in before you can comment on or make changes to this bug.