Bug 15466 - 2.6.33 dies on modprobe
2.6.33 dies on modprobe
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: PCI
All Linux
: P1 normal
Assigned To: drivers_pci@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-03-07 09:45 UTC by Maciej Rutecki
Modified: 2010-10-28 18:15 UTC (History)
6 users (show)

See Also:
Kernel Version: 2.6.33
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-03-07 09:45:21 UTC
Subject    : 2.6.33 dies on modprobe
Submitter  : M G Berberich <berberic@fmi.uni-passau.de>
Date       : 2010-02-28 22:12
Message-ID : 20100228221257.GA8858@invalid
References : http://marc.info/?l=linux-kernel&m=126739570819208&w=2

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jesse Barnes 2010-03-08 18:16:16 UTC
Looks like a crash in a networking driver?  At least init_nic occurs in the first backtrace...
Comment 2 M G Berberich 2010-03-08 22:37:53 UTC
probably not. From lkml:

>I don't think it's forcedeth. forcedeth just happens to be the first
>module that get's loaded in startup. It crashes with any other module
>too (I tried ohci_hcd).
Comment 3 Rafael J. Wysocki 2010-03-21 19:30:04 UTC
Handled-By : Américo Wang <xiyou.wangcong@gmail.com>
Comment 4 Jan Lamecki 2010-05-10 21:57:08 UTC
I've got similar problems with 2.6.33.3 kernel. It went away when using plain old GNU ld instead of GNU gold. So if you see something like:
$ ld -version
GNU gold (GNU Binutils for Debian 2.20.51-system.20100418) 1.9
It may be the problem.

Probably the same problem:
https://bugzilla.kernel.org/show_bug.cgi?id=15392
Comment 5 M G Berberich 2010-05-11 16:58:42 UTC
Same here. I also have GNU gold utils:

  GNU gold (GNU Binutils for Debian 2.20.1-system.20100303) 1.9

I'll try with standard GNU-utils as soon as I have some time to do so.
Comment 6 M G Berberich 2010-05-12 11:06:29 UTC
The kernel works fine if linked with the standard GNU-ld instead of gold-ld.
Comment 7 Jesse Barnes 2010-05-12 16:57:17 UTC
Ok, thanks for the update.  Sounds like a bug in either gold or the kernel's linker scripts somehow.

Note You need to log in before you can comment on or make changes to this bug.