Bug 15439 - Laptop does consume more power when booted "cold" -- Thinkpad X200s
Laptop does consume more power when booted "cold" -- Thinkpad X200s
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-03-03 23:09 UTC by johannes.schlatow
Modified: 2010-08-08 23:17 UTC (History)
5 users (show)

See Also:
Kernel Version: >=2.6.32
Tree: Mainline
Regression: Yes


Attachments
powertop dump (cold boot) (2.87 KB, text/plain)
2010-03-04 11:15 UTC, johannes.schlatow
Details
powertop dump (warm boot) (2.83 KB, text/plain)
2010-03-04 11:16 UTC, johannes.schlatow
Details
powertop dump with idle=halt, cold boot (2.61 KB, text/plain)
2010-03-06 13:47 UTC, johannes.schlatow
Details
powertop dump with idle=halt, warm boot (2.37 KB, text/plain)
2010-03-06 13:47 UTC, johannes.schlatow
Details
/proc/acpi (cold boot) (14.44 KB, text/plain)
2010-03-06 13:48 UTC, johannes.schlatow
Details
/proc/acpi (warm boot) (14.44 KB, text/plain)
2010-03-06 13:49 UTC, johannes.schlatow
Details

Description johannes.schlatow 2010-03-03 23:09:24 UTC
Since version 2.6.32 the power consumption in idle state of my Thinkpad x200s is 1-1.5 watt higher after a cold boot. "Cold" means that it has to be turned off at least 1 hour. When I reboot the laptop or shutdown and turn it on immediately, I have a power consumption (measured with powertop) as low as usual.

Resetting the laptop after grub has been loaded does "solve" the problem.

I suspect there is a part of hardware that is not initialized well, but I was not able to locate that part yet. That is why I waited for the next release before reporting this bug hoping there would be anyone who can give more specific information.

Here is what I can exclude from being responsable:
I tried updating the BIOS and disabling some parts of the integrated hardware (bluetooth, modem). WLAN is turned off via a hardware switch. Tried with and without intel_kms and devtmpfs. Raising the timeout in grub up to 15s does not change anything either.
Comparing the output of dmesg in both cases (cold vs. warm boot) did not show any notable difference.
Comment 1 Andrew Morton 2010-03-03 23:18:43 UTC
i'll assign this to PM for now.  Rafael, can you please take a look, maybe reassign it?

it's a 2.6.32->2.6.33 regression btw.
Comment 2 Rafael J. Wysocki 2010-03-04 00:17:06 UTC
Suppose it's an ACPI issue.

What CPU is there in the box?
Comment 3 johannes.schlatow 2010-03-04 00:43:53 UTC
It's a Intel SL9400.
Comment 4 Zhang Rui 2010-03-04 08:58:16 UTC
please attach the powertop -d output in both cases.
does the power consumption drop to normal after a S3?
Comment 5 johannes.schlatow 2010-03-04 11:15:50 UTC
Created attachment 25354 [details]
powertop dump (cold boot)
Comment 6 johannes.schlatow 2010-03-04 11:16:19 UTC
Created attachment 25355 [details]
powertop dump (warm boot)
Comment 7 johannes.schlatow 2010-03-04 16:49:45 UTC
The power consumption does not drop to normal after S3.
Comment 8 Zhang Rui 2010-03-05 03:06:52 UTC
please boot with idle=halt (to disable the processor c-state) and attach the powertop -d in both cases.
so we can verify if this is a processor related issue.
please also attach the output of "grep . /proc/acpi/* -R" in both cases.
Comment 9 johannes.schlatow 2010-03-06 13:47:17 UTC
Created attachment 25384 [details]
powertop dump with idle=halt, cold boot
Comment 10 johannes.schlatow 2010-03-06 13:47:49 UTC
Created attachment 25385 [details]
powertop dump with idle=halt, warm boot
Comment 11 johannes.schlatow 2010-03-06 13:48:41 UTC
Created attachment 25386 [details]
/proc/acpi (cold boot)
Comment 12 johannes.schlatow 2010-03-06 13:49:04 UTC
Created attachment 25387 [details]
/proc/acpi (warm boot)
Comment 13 Zhang Rui 2010-03-08 02:01:49 UTC
hmm, it seems that the LCD brightness is set to differernt levels(40 vs 35), but I don't think this brings the 1.5w difference. could you please make a double check?

could you please compile the ACPI battery driver in, rebuild and reboot to single user mode, and then check if the problem still exists? (initialise as few devices as possible)
Comment 14 johannes.schlatow 2010-03-08 13:41:43 UTC
When powertop was running the LCD brightness was set to the lowest level. I just raised the level afterwards to work easily in the terminal.

Regarding the ACPI battery driver:
Do you mean I should compile the kernel with minimal ACPI features?
Comment 15 Zhang Rui 2010-03-10 02:42:05 UTC
(In reply to comment #14)
> When powertop was running the LCD brightness was set to the lowest level. I
> just raised the level afterwards to work easily in the terminal.
> 
> Regarding the ACPI battery driver:
> Do you mean I should compile the kernel with minimal ACPI features?

no, we compile ACPI battery driver in to get the power consumption info in single user mode. so just compiling this driver in is okay.
Comment 16 johannes.schlatow 2010-03-10 23:06:52 UTC
The problem exists in single user mode as well.
Comment 17 johannes.schlatow 2010-08-08 23:17:54 UTC
This bug became outdated with 2.6.35. This means that I can't reproduce it anymore.

Note You need to log in before you can comment on or make changes to this bug.