Bug 15436 - PCI card inserted in Thinkpad Dock II docking station not visible
Summary: PCI card inserted in Thinkpad Dock II docking station not visible
Status: RESOLVED OBSOLETE
Alias: None
Product: Drivers
Classification: Unclassified
Component: PCI (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_pci@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-03 16:33 UTC by laramichaels1978
Modified: 2012-07-05 15:40 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31
Tree: Mainline
Regression: No


Attachments
dmesg with pci=assign-busses (52.95 KB, text/plain)
2010-03-03 16:36 UTC, laramichaels1978
Details
lspci -vvv with pci=assign-busses (13.49 KB, text/plain)
2010-03-03 16:36 UTC, laramichaels1978
Details
output of acpidump (241.83 KB, application/octet-stream)
2010-03-10 20:34 UTC, laramichaels1978
Details

Description laramichaels1978 2010-03-03 16:33:31 UTC
Hello,

This might be related to these earlier reports on the LKML

http://lkml.indiana.edu/hypermail/linux/kernel/0607.0/1409.html

http://lkml.indiana.edu/hypermail/linux/kernel/0901.1/00438.html

On a Thinkpad Dock II, there is a PCI video card system which is not visible on my Linux system. (I have tested the card on an old desktop and it is detected.)

I am attaching the output of dmesg, lspci -vvv and acpidump. Notice that in the second of these I can see the docking station itself; like in the second problem report quoted above, the card itself doesn't show up in lspci, though.

Thanks for any time you can devote to this,

lara
Comment 1 laramichaels1978 2010-03-03 16:35:17 UTC
Forgot to mention: based on information online, I have tried booting with acpi=off, pci=assign-busses, pci=routeirq, pci=noacpi and pci=nobios to no avail.
Comment 2 laramichaels1978 2010-03-03 16:36:02 UTC
Created attachment 25340 [details]
dmesg with pci=assign-busses
Comment 3 laramichaels1978 2010-03-03 16:36:36 UTC
Created attachment 25341 [details]
lspci -vvv with pci=assign-busses
Comment 4 laramichaels1978 2010-03-10 20:34:45 UTC
Created attachment 25459 [details]
output of acpidump
Comment 5 Bjorn Helgaas 2010-03-11 19:56:55 UTC
[[Ugh, I fat-fingered the [Bug 15436] in the subject, so the last one
went to the wrong bugzilla.]]
[Updating this thread with the bugzilla pointer and my current theory]

http://bugzilla.kernel.org/show_bug.cgi?id=15436

I first thought this was an ACPI or dock problem, but I now think
this is a PCI issue after all, since the machine was booted in the
dock and no dock/undock events are involved.

From this lspci output:

  00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev 81)
	Bus: primary=00, secondary=02, subordinate=13, sec-latency=64
	I/O behind bridge: 00004000-00009fff
	Memory behind bridge: c0200000-cfffffff
	Prefetchable memory behind bridge: e8000000-efffffff

  02:03.0 PCI bridge: Texas Instruments PCI2032 PCI Docking Bridge (prog-if 01)
	Bus: primary=02, secondary=0b, subordinate=13, sec-latency=68
	I/O behind bridge: 00004000-00004fff
	Memory behind bridge: 84000000-8bffffff
	Prefetchable memory behind bridge: 8c000000-93ffffff

  0b:02.0 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
	Bus: primary=0b, secondary=0c, subordinate=0f, sec-latency=176

  0b:02.1 CardBus bridge: Texas Instruments PCI1420 PC card Cardbus Controller
	Bus: primary=0b, secondary=10, subordinate=13, sec-latency=176

It looks like the dock PCI slot should appear as 0b:00 (as it does in the
report at http://lkml.indiana.edu/hypermail/linux/kernel/0607.0/1409.html).
We do see the CardBus bridges in the dock.  The fact that we don't see the
video card, which should be on the same bus, makes me suspect that the
dock's PCI slot is bad.

Note You need to log in before you can comment on or make changes to this bug.