Bug 15431 - MTRR allocation failed. Graphics performance may suffer.
Summary: MTRR allocation failed. Graphics performance may suffer.
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 blocking
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-03-03 01:31 UTC by Artem S. Tashkinov
Modified: 2010-07-23 19:59 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.34
Tree: Mainline
Regression: No


Attachments
Hardware and software info (41.95 KB, application/octet-stream)
2010-03-03 01:31 UTC, Artem S. Tashkinov
Details

Description Artem S. Tashkinov 2010-03-03 01:31:20 UTC
Created attachment 25331 [details]
 Hardware and software info

Intel Graphics HD video adapter doesn't perform well in OpenGL mode probably due to this error.

I have Intel Core i5 650 CPU, 4GB of RAM and Intel H55 based motherboard.

Some relevant hardware software/information is attached.
Comment 1 Artem S. Tashkinov 2010-03-03 10:45:06 UTC
I have enabled these options in the kernel and this error message is now gone:

CONFIG_MTRR_SANITIZER=y
CONFIG_MTRR_SANITIZER_ENABLE_DEFAULT=1
CONFIG_MTRR_SANITIZER_SPARE_REG_NR_DEFAULT=1

Unfortunately OpenGL performance is still unsatisfactory:

[birdie@localhost ~]$ glxgears
4044 frames in 5.0 seconds = 808.746 FPS
4012 frames in 5.0 seconds = 802.318 FPS

However this issue isn't a Linux kernel concern.

Feel free to close this bug report if the aforementioned options are a must for the i915 drm functioning.
Comment 2 Jesse Barnes 2010-07-23 19:59:31 UTC
note: glxgears isn't a benchmark.  If you have performance problems with real apps you should file them at bugs.freedesktop.org.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.