Bug 15416 - Synaptic touchpad not working - psmouse.c timeout in the logs
Synaptic touchpad not working - psmouse.c timeout in the logs
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: Jiri Kosina
:
: 22462 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-28 21:14 UTC by Marcin Naglik
Modified: 2011-02-22 22:05 UTC (History)
8 users (show)

See Also:
Kernel Version: 2.6.32-020632-generic, 2.6.33, 2.6.14
Tree: Mainline
Regression: No


Attachments
dmesg output after running with i8042.nomux (87.80 KB, text/plain)
2010-02-28 21:27 UTC, Marcin Naglik
Details
dmesg output after running with i8042.nomux and i8042.debug (119.30 KB, text/plain)
2010-02-28 21:27 UTC, Marcin Naglik
Details
dmesg output with psmouse=10 and i8042.nomux=1 kernel options (53.89 KB, text/plain)
2010-06-18 11:28 UTC, khiraly
Details
cat /proc/bus/input/devices >devices.txt (2.94 KB, text/plain)
2010-06-18 11:29 UTC, khiraly
Details
Output of evtest (sudo ./ev /dev/input/event10) (121.02 KB, text/plain)
2010-06-18 11:31 UTC, khiraly
Details
[PATCH] Input: introduce 'notimeout' blacklist for Dell Vostro V13 (3.02 KB, patch)
2010-12-29 13:08 UTC, Jiri Kosina
Details | Diff

Description Marcin Naglik 2010-02-28 21:14:24 UTC
Exists in most recent kernel including 2.6.33

Distribution: Ubuntu 9.10, 9.04, 10.04 (alpha 3)

Hardware Environment: Dell Vostro V13 laptop

Software Environment: Linux marcin-laptop 2.6.32-020632-generic #020632 SMP Thu Dec 3 10:58:45 UTC 2009 i686 GNU/Linux


Problem Description: The touchpad is recognized with i8042.nomux option however complately not working dmesg logs tons tons of:
psmouse.c: bad data from KBC - timeout

when clicking, tapping the touchpad

Steps to reproduce:
Run the system with i8042.nomux option. Running without i8042.nomux detects the touchpad as PS/2 Generic Mouse.


I did quite huge research on the topic and know that other people have the same problem on their Dell Vostro V13.
Tested all the i8042.xxx options, other ACPI options. Also tested number of bios settings (including disable usb legacy support). Also did upgrade to A02 (newest Dell bios for the machine)
Comment 1 Marcin Naglik 2010-02-28 21:27:05 UTC
Created attachment 25283 [details]
dmesg output after running with i8042.nomux
Comment 2 Marcin Naglik 2010-02-28 21:27:52 UTC
Created attachment 25284 [details]
dmesg output after running with i8042.nomux and i8042.debug
Comment 3 khiraly 2010-06-18 11:28:03 UTC
Created attachment 26839 [details]
dmesg output with psmouse=10 and i8042.nomux=1 kernel options
Comment 4 khiraly 2010-06-18 11:29:00 UTC
Created attachment 26840 [details]
cat /proc/bus/input/devices >devices.txt
Comment 5 khiraly 2010-06-18 11:31:52 UTC
Created attachment 26841 [details]
Output of evtest (sudo ./ev /dev/input/event10)
Comment 6 khiraly 2010-06-18 11:32:47 UTC
I have the same problem with the same laptop (dell vostro v13 13.3") as the reporter.
My kernel is the default ubuntu 10.04: 2.6.32-22-generic

There is an ubuntu bug* #380126, where lot of v13 users confirms this bug, but not much additional info is there.

I tried to digg a bit more. I read* on bug #6105 , that maybe psmouse.rate=40 helps, so I modified /etc/default/grub line:
GRUB_CMDLINE_LINUX=""
to:
GRUB_CMDLINE_LINUX="psmouse.rate=40 i8042.nomux=1"

Then sudo update-grub, and rebooted. 

The result is lot of 
[   86.110461] psmouse.c: bad data from KBC - timeout
*when* I move the mouse around it adds to the dmesg line.
The mouse pointer stays at the middle of the screen and does not move.
(it is not working in gdm either)

I have attached a dmesg output, dmesg_psmouse_10.txt.

I also redid with psmouse.rate=20 and 10 too.

--
I have also read* on bug #496314, I should test my touchpad with evtest 
( http://people.freedesktop.org/~whot/evtest.c ) program.

So I downloaded, and tested it. The result is attached as evtest_output.txt.
I tested it with sudo ./ev /dev/input/event10, as in file /proc/bus/input/devices shows the ps/2 mouse as event10.

I also attached my /proc/bus/input/devices output as devices.txt


If there are any other test, what I can do, just ask.

Best regards, 
 Khiraly


---
Links:

bug #380126: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/380126

bug   #6105: https://bugzilla.kernel.org/show_bug.cgi?id=6105

bug #496314: https://bugzilla.redhat.com/show_bug.cgi?id=496314
Comment 7 Eugenia Loli-Queru 2010-12-28 08:21:46 UTC
I think the bug is with the touchpad itself. I uninstalled DELL's in-home tweaked driver on Win7, and installed Synaptics' generic driver, and even Synaptics itself on Windows thinks that this is a PS/2 mouse and not a touchpad! So I think the bug is with either the BIOS or the firmware of the touchpad, advertising itself as a mouse...

There are a myriads of bug reports about it on Ubuntu, Red Hat, and Mandriva, and many forum posts too, but I think the only thing it can be done is to hardcode the Product ID on the Linux synaptics driver in order to recognize it as a touchpad and not as a PS/2 mouse -- just like DELL did it for its own Windows drivers. I don't know what the policy is on Linux though about getting around buggy hardware.
Comment 8 Jiri Kosina 2010-12-29 13:08:01 UTC
Created attachment 41862 [details]
[PATCH] Input: introduce 'notimeout' blacklist for Dell Vostro V13

Testing with this patch would be appreciated.
Comment 9 diroots 2011-01-06 09:03:30 UTC
Hello J(In reply to comment #8)
> Created an attachment (id=41862) [details]
> [PATCH] Input: introduce 'notimeout' blacklist for Dell Vostro V13
> 
> Testing with this patch would be appreciated.

Patch tested yesterday on a 2.6.32 kernel (linux LMDE; debian style box), good news, now I have a fully functional synaptics touchpad on the Vostro V13, many thanks!!!

now my touchpad is identified as SynPS/2 Synaptics TouchPad in gpointing-device-settings, and I could define all options like vertical, horizontal and circle scroll, I can now also use zoom with 2 fingers in apps that support this feature. 

Very happy to get back a fully functional Touchpad

For others to test, I commented my installation here : 
https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-input-synaptics/+bug/380126?comments=all


Once again, many thanks && Happy new year!
Comment 10 Dmitry Torokhov 2011-01-06 10:10:43 UTC
There was one report that with the patch applied touchpad is dead on resume, could you please verify that shutdown and suspend/resume work properly? Thanks.
Comment 11 diroots 2011-01-06 10:44:05 UTC
I did not shutdown since I installed the patch, but I closed my screen last night and my computer went to suspend. and this morning, touchpad is still working. 

was the report of the dead touchpad for a 2.6.32 kernel?
Comment 12 Rafael J. Wysocki 2011-01-15 22:02:15 UTC
*** Bug 22462 has been marked as a duplicate of this bug. ***
Comment 13 Jiri Kosina 2011-01-16 10:11:00 UTC
commit f8313ef1f448006207f12c107123522c8bc00f15
Author: Jiri Kosina <jkosina@suse.cz>
Date:   Sat Jan 8 01:37:26 2011 -0800

    Input: i8042 - introduce 'notimeout' blacklist for Dell Vostro V13

in Linus' tree, closing.
Comment 14 Andrea Cimitan 2011-02-08 16:56:29 UTC
I have this bug with ubuntu mainline kernel, is somewhat related to this?
https://bugs.launchpad.net/ubuntu/+source/linux/+bug/715267
Comment 15 Dmitry Torokhov 2011-02-08 18:04:08 UTC
Andrea, was this happening before or is it just started to happen?
Comment 16 Andrea Cimitan 2011-02-08 18:08:32 UTC
didn't happen with patched 2.6.37, don't know if it's related to ubuntu or vanilla 2.6.38
Comment 17 Dmitry Torokhov 2011-02-09 00:22:56 UTC
2.6.37 patched with what? This particular patch?
Comment 18 Andrea Cimitan 2011-02-19 14:28:48 UTC
@17 yes
and I can confirm the bug with latest ubuntu natty kernel
Comment 19 Dmitry Torokhov 2011-02-22 22:05:22 UTC
Ok, so if patched mainline works then please ask Ubunty guys to backport it to their kernel.

Note You need to log in before you can comment on or make changes to this bug.