Bug 15400 - tg3: Problem fetching invariants of chip, aborting.
Summary: tg3: Problem fetching invariants of chip, aborting.
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Matt Carlson
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-26 06:41 UTC by Michael Husmann
Modified: 2012-07-05 15:33 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33
Tree: Mainline
Regression: No


Attachments

Description Michael Husmann 2010-02-26 06:41:34 UTC
The driver can not be loaded during boot and quits with the error message above:
"tg3: Problem fetching invariants of chip, aborting."

This is the output of dmesg:
[    1.244889] tg3.c:v3.106 (January 12, 2010
[    1.244906] tg3 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    1.244914] tg3 0000:04:00.0: setting latency timer to 64
[    1.247613] tg3 mdio bus: probed
[    1.247631] tg3: Problem fetching invariants of chip, aborting

The driver can be loaded when running:
modprobe -r tg3
modprobe broadcom
modprobe tg3

Unfortunately this is very annoying.

Running Kernel: 2.6.33 x86_64,
CPU: Quad core Intel Core i7
Network Card: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe driver tg3 v: 3.106 BusID: 04:00.0
Comment 1 Matt Carlson 2010-03-02 22:44:23 UTC
Yes.  This is a known problem.  The generally accepted solution is to add the following to /etc/modprobe.d/dist.conf or its equivalent:

install tg3 /sbin/modprobe broadcom; /sbin/modprobe --ignore-install tg3

The real solution is to have phylib load the broadcom module.  That work is still left undone at the moment.
Comment 2 Michael Husmann 2010-03-03 07:51:18 UTC
Matt,

I just created a 'dist.conf' file within the /etc/modprobe.d/ directory containing the command you described. Then I rebooted the computer but still the same problem. Obviously that file is not recognized.

Can you give me a hint.

Next to that if I could contribute in helping the broadcom module to be loaded properly I would do so.

Kind regards,
Michael
Comment 3 Matt Carlson 2010-03-03 17:34:08 UTC
What distro are you running?  I'll see if I can debug the problem firsthand.

In the meantime, I'm imagining there might be several modprobe related problems.  Did you have to create the /etc/modprobe.d directory?  If so, perhaps modprobe does not honor that style of configuration yet.  If this was the problem, moving the line to /etc/modprobe.conf should fix it.  That is, unless it doesn't recognize the syntax.  I don't think the workaround syntax is new though.

I was hoping somebody who understood the process more would step up and do the module loading work, but that hasn't happened yet.  Just last week I started scoping out what would be required to do this myself.  I'm afraid I can't commit to a timeline though.
Comment 4 Michael Husmann 2010-03-04 17:37:40 UTC
Matt,

distro is Sidux.

There is a /etc/modeprobe.d directory and as written I've put that file into it but it was not using during boot time. I'll try to figure out why.

If you can tell me the Todo's concerning the module loading work I would give it a try.

Regards,
Michael
Comment 5 Matt Carlson 2010-04-05 22:50:08 UTC
Did you ever get anywhere with this?

David Woodhouse just posted a patch upstream that should fix module loading.

http://marc.info/?l=linux-netdev&m=127020633331445&w=1

Perhaps you could give that a try?
Comment 6 Michael Husmann 2010-04-06 07:23:17 UTC
Hi Matt,

I was quite busy during the last weeks so I found no time to deal with this
subject.

It's nice to read that there is a patch. I'll give it a try latest on
Thursday.

Thanks and regards,
Michael

2010/4/6 <bugzilla-daemon@bugzilla.kernel.org>

> https://bugzilla.kernel.org/show_bug.cgi?id=15400
>
>
>
>
>
> --- Comment #5 from Matt Carlson <mcarlson@broadcom.com>  2010-04-05
> 22:50:08 ---
> Did you ever get anywhere with this?
>
> David Woodhouse just posted a patch upstream that should fix module
> loading.
>
> http://marc.info/?l=linux-netdev&m=127020633331445&w=1
>
> Perhaps you could give that a try?
>
> --
> Configure bugmail: https://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 7 Matt Carlson 2010-05-18 18:43:48 UTC
Hi Michael.  How did the testing go?
Comment 8 Michael Husmann 2010-05-19 05:55:00 UTC
Hi Matt,

well, the module was properly loaded during boot-time using the kernel 2.6.33, now with the most recent kernel 2.6.34 the problem is back again. So I have to install the module manually.

dmesg gives the following report:
[    1.207098] tg3.c:v3.108 (February 17, 2010)
[    1.207112] tg3 0000:04:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[    1.207120] tg3 0000:04:00.0: setting latency timer to 64
[    1.209157] tg3 mdio bus: probed
[    1.209159] tg3 0000:04:00.0: (unregistered net_device): No PHY devices
[    1.209176] tg3 0000:04:00.0: (unregistered net_device): Problem fetching invariants of chip, aborting
[    1.210072] tg3 0000:04:00.0: PCI INT A disabled
Comment 9 Michael Husmann 2010-05-22 09:21:35 UTC
Hi Matt,

today I installed the most recent kernel for my distro (Sidux) 2.6.34-0.slh.4-sidux-amd64
the module is now loaded at boot time properly again.

Regards,
Michael

Note You need to log in before you can comment on or make changes to this bug.