Bug 15359 - ALPS Touchpad in Compaq Mini 311 recognized as "ImPS/2 Generic Wheel Mouse"
Summary: ALPS Touchpad in Compaq Mini 311 recognized as "ImPS/2 Generic Wheel Mouse"
Status: RESOLVED DUPLICATE of bug 14660
Alias: None
Product: Drivers
Classification: Unclassified
Component: Input Devices (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_input-devices
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-02-20 05:04 UTC by Miroshnikov Andrey
Modified: 2010-05-08 06:03 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32.8
Tree: Mainline
Regression: No


Attachments
cat /proc/bus/input/devices (2.78 KB, text/plain)
2010-02-20 05:22 UTC, Miroshnikov Andrey
Details
lshal (98.25 KB, text/plain)
2010-02-20 05:25 UTC, Miroshnikov Andrey
Details
lspci -vv (10.77 KB, text/plain)
2010-02-20 05:26 UTC, Miroshnikov Andrey
Details
dmesg (65.71 KB, text/plain)
2010-02-20 05:27 UTC, Miroshnikov Andrey
Details
photo (111.93 KB, image/jpeg)
2010-02-20 05:41 UTC, Miroshnikov Andrey
Details

Description Miroshnikov Andrey 2010-02-20 05:04:30 UTC

    
Comment 1 Miroshnikov Andrey 2010-02-20 05:19:04 UTC
Using ALPS touchpad in my Compaq Mini 311 netbook. I can't use it with synaptics driver because it recognized by kernel as "ImPS/2 Generic Wheel Mouse", and not as touchpad.
There is similar bug here: http://bugzilla.kernel.org/show_bug.cgi?id=13134
And there is resolved by adding just one string with touchpad's hardware signature in "alps.c" driver in kernel, and i think we need a similar solution, but i don't know where to see touchpad's hardware signature (like '0x32, 0x02, 0x14').
I'm tried it on Ubuntu 9.10 and ArchLinux - problems affects.
And ofcourse, touchpad working fine in Weendows.

P.S. sorry for my English.
Comment 2 Miroshnikov Andrey 2010-02-20 05:22:47 UTC
Created attachment 25124 [details]
cat /proc/bus/input/devices
Comment 3 Miroshnikov Andrey 2010-02-20 05:25:59 UTC
Created attachment 25125 [details]
lshal
Comment 4 Miroshnikov Andrey 2010-02-20 05:26:42 UTC
Created attachment 25126 [details]
lspci -vv
Comment 5 Miroshnikov Andrey 2010-02-20 05:27:30 UTC
Created attachment 25127 [details]
dmesg
Comment 6 Miroshnikov Andrey 2010-02-20 05:41:59 UTC
Created attachment 25128 [details]
photo
Comment 7 Miroshnikov Andrey 2010-02-22 05:55:18 UTC
It has turned out not so simply as I thought.
The hardware id I found in "dmesg | grep psmouse" in Ubuntu:

[    9.591602] psmouse serio1: ID: 73 02 64

For some reason dmesg in ArchLinux dir non show me this.

I added into "alps.c" this string:

...
static const struct alps_model_info alps_model_data[] = {
        { { 0x73, 0x02, 0x64 }, 0x88, 0xff, ALPS_WHEEL },
        { { 0x32, 0x02, 0x14 }, 0xf8, 0xf8, ALPS_PASS | ALPS_DUALPOINT }, /* Toshiba Salellite Pro M10 */
...

but now after loading module "psmouse" appears two devices:
# dmesg
...
[ 5334.058926] input: PS/2 Mouse as /devices/platform/i8042/serio1/input/input15
[ 5334.092718] input: AlpsPS/2 ALPS GlidePoint as /devices/platform/i8042/serio1/input/input16


and when I touching a touchpad or pressing buttons on it, events are incoming from "PS/2 Mouse", and "AlpsPS/2 ALPS GlidePoint" are always silent. I tried load synaptics driver and assotiated it with both "PS/2 Mouse" and "AlpsPS/2 ALPS GlidePoint" devices by HAL, it don't work in both case.
Also, when i'm used "ImPS/2 Generic Wheel Mouse" before patching alps.c, vertical scroll on touchpad was work fine, but now it is not.
Now i don't know what to do.
Comment 8 orgoz2 2010-03-14 13:01:26 UTC
Same problem on a HP DM3-1080EF. Tried with Ubuntu 9.10 and ArchLinux.
Comment 10 Miroshnikov Andrey 2010-04-01 08:58:26 UTC
May be it works on HP DM3-1080EF, but it is not on HP Compaq Mini 311 :(
Comment 11 Dmitry Torokhov 2010-05-08 06:02:49 UTC
Nope, does not work on DM3 either.
Comment 12 Dmitry Torokhov 2010-05-08 06:03:18 UTC

*** This bug has been marked as a duplicate of bug 14660 ***

Note You need to log in before you can comment on or make changes to this bug.