Bug 15347 - eeepc-laptop module not loading by default
eeepc-laptop module not loading by default
Status: CLOSED DUPLICATE of bug 15182
Product: Drivers
Classification: Unclassified
Component: Platform
All Linux
: P1 low
Assigned To: Zhang Rui
:
Depends on:
Blocks: 56331
  Show dependency treegraph
 
Reported: 2010-02-18 17:05 UTC by Scott Warner
Modified: 2013-04-09 06:23 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments

Description Scott Warner 2010-02-18 17:05:52 UTC
The eeepc-laptop module does not load by default, nor will it load using modprobe eeepc-laptop using kernel 2.6.32 and 2.6.33-rc8

Reports:
http://bugs.archlinux.org/task/17616

http://bbs.archlinux.org/viewtopic.php?id=87316

http://forums.eeebuntu.org/viewtopic.php?f=56&t=5138

Current fix is to add acpi_osi=Linux to boot options
Comment 1 Zhang Rui 2010-02-22 05:59:25 UTC
this seems to be a duplicate of bug #15182, in which the ATKD device doesn't work if _OSI(Windows 2009) returns TRUE.

Scott,
Are you using a eeepc 1005p?
If not, please attach the acpidump of your laptop.
Comment 2 Len Brown 2010-02-23 03:25:02 UTC
Scott,
Please try booting with acpi_osi="!Windows 2009"
and verify that works the same as bootting with acpi_osi=Linux
Comment 3 Scott Warner 2010-02-23 16:43:34 UTC
When booting using acpi_osi="!Windows 2009" the eeepc_laptop module does not load, and modprobe fails.

I am running a 1005HA-PU1X (That is commonly referred to as 1005P, correct?)

My uname -a
Linux scott-netbook 2.6.32 #1 SMP Thu Feb 18 14:18:07 EST 2010 i686 GNU/Linux

Please tell me what information you would like, and Ill add more.
Comment 4 Zhang Rui 2010-02-24 01:35:24 UTC
please (In reply to comment #3)
> When booting using acpi_osi="!Windows 2009" the eeepc_laptop module does not
> load, and modprobe fails.
> 
this is weird.
please attach the output of "grep . /sys/bus/acpi/drivers/*/*/path".

maybe you have loaded the asus-laptop first?

> I am running a 1005HA-PU1X (That is commonly referred to as 1005P, correct?)
> 
I'm not sure, please attach the acpidump.
And please look at bug #15182 and verify if it's same as the problem on your laptop.
Comment 5 Scott Warner 2010-02-24 15:40:12 UTC
(In reply to comment #4)
> please (In reply to comment #3)
> > When booting using acpi_osi="!Windows 2009" the eeepc_laptop module does not
> > load, and modprobe fails.
> > 
> this is weird.
> please attach the output of "grep . /sys/bus/acpi/drivers/*/*/path".

Here is the output, with both the eeepc module loaded and not:
http://pastebin.com/DhLyXy8L

> maybe you have loaded the asus-laptop first?
> 
> > I am running a 1005HA-PU1X (That is commonly referred to as 1005P, correct?)
> > 
> I'm not sure, please attach the acpidump.

Here is the ACPI dump:
http://pastebin.com/69QKb41g

> And please look at bug #15182 and verify if it's same as the problem on your
> laptop.

I believe that the root cause of bug #15182 could be the bug I described here, although I have not had any issues with the backlight.
With the eeepc module loaded, the /sys/class/backlight/acpi_video0/actual_brightness value does change, Ill test if it does not without the module later today
Comment 6 Zhang Rui 2010-02-25 01:34:25 UTC
(In reply to comment #3)
> When booting using acpi_osi="!Windows 2009" the eeepc_laptop module does not
> load, and modprobe fails.
> 
I read the acpidump you attached and I'm still wondering why acpi_osi="!Windows 2009" doesn't work for you.
please attach the full dmesg output when using acpi_osi="!Windows 2009".
Comment 7 Scott Warner 2010-02-25 14:49:26 UTC
(In reply to comment #6)
> (In reply to comment #3)
> > When booting using acpi_osi="!Windows 2009" the eeepc_laptop module does not
> > load, and modprobe fails.
> > 
> I read the acpidump you attached and I'm still wondering why acpi_osi="!Windows
> 2009" doesn't work for you.
> please attach the full dmesg output when using acpi_osi="!Windows 2009".

Dmesg output:
http://pastebin.com/YPLDnYpn

And to follow up from my last response, with the module not loaded (eg, booting osi="!Windows 2009"), using the brightness up/down keys changes the /sys/class/backlight/acpi_video0/actual_brightness value by 2. I think this and bug #15182 could very well be dulpicates of each other then.

Would you also like me to get some input from another user?
Comment 8 Zhang Rui 2010-02-26 01:16:08 UTC
>[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32 root=UUID=049b51af-a885-4a96-a133-8b80351c15c7 ro acpi_osi=!Windows 2009

this is weird, usually we should see acpi_osi="!Windows 2009" in the kernel command line.
can you please enter the grub menu before kernel starts to run and add the boot option manually?
Comment 9 Zhang Rui 2010-02-26 01:19:17 UTC
what distribution are you using?
Comment 10 Scott Warner 2010-02-26 03:32:43 UTC
(In reply to comment #8)
> >[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32 root=UUID=049b51af-a885-4a96-a133-8b80351c15c7 ro acpi_osi=!Windows 2009
> 
> this is weird, usually we should see acpi_osi="!Windows 2009" in the kernel
> command line.
> can you please enter the grub menu before kernel starts to run and add the boot
> option manually?

When entered manually, I have the same results.


I am running Debian unstable with some Eeebuntu packages. The 2.6.32 kernel had Debian patches and a video fix, I just built .33 today with the same issues.

The bootloader is Grub2, Ubuntu Jaunty version 1.96.
Comment 11 Scott Warner 2010-02-26 03:39:06 UTC
(In reply to comment #8)
> >[    0.000000] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-2.6.32 root=UUID=049b51af-a885-4a96-a133-8b80351c15c7 ro acpi_osi=!Windows 2009
> 
> this is weird, usually we should see acpi_osi="!Windows 2009" in the kernel
> command line.
> can you please enter the grub menu before kernel starts to run and add the boot
> option manually?

I just tested this again using acpi_osi=""!Windows 2009"", and it works.
Interestingly, according to dmesg it was booted with this command:
BOOT_IMAGE=/boot/vmlinuz-2.6.33 root=UUID=049b51af-a885-4a96-a133-8b80351c15c7 ro acpi_osi= 2009


Full dmesg:
http://pastebin.com/rV1WQwTp
Comment 12 Zhang Rui 2010-02-26 05:34:53 UTC
Okay, this is a duplicate of bug #15182.
Let's work on this in that bug report. :)

*** This bug has been marked as a duplicate of bug 15182 ***

Note You need to log in before you can comment on or make changes to this bug.