Bug 1534 - PCI: no interrupt route for 00:00:03 pin B
Summary: PCI: no interrupt route for 00:00:03 pin B
Status: REJECTED UNREPRODUCIBLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Config-Interrupts (show other bugs)
Hardware: i386 Linux
: P2 normal
Assignee: Luming Yu
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-11-12 21:53 UTC by Luming Yu
Modified: 2005-08-21 19:39 UTC (History)
1 user (show)

See Also:
Kernel Version: Lastest 2.4 ia64 + Latest ACPI
Tree: Mainline
Regression: ---


Attachments
DSDT (148.21 KB, text/plain)
2003-12-10 02:37 UTC, Luming Yu
Details

Description Luming Yu 2003-11-12 21:53:57 UTC
Distribution:

RH

Hardware Environment:
4 way 800M Itanium, Lion

Software Environment:
	1.Bk pull form http://lia64.bkbits.net/linux-ia64-2.4 on 11/11 
(Shanghai time)
	2.Bk pull from http://linux-acpi.bkbits.net/linux-acpi-test-2.4.22 on 
11/11 (Shanhai time)

Problem Description:
There is " PCI: no interrupt route for 00:00:03 pin B" in dmesg

Steps to reproduce:
just boot
Comment 1 Len Brown 2003-11-19 17:34:27 UTC
comments from bjorn:

> 2.PCI: no interrupt route for 00:00:03 pin B

You say this is a known issue for 2.6, but I can't find any details
or discussion about it.  It looks to me like a firmware problem.
The function at 00:00:03.3 (2.6 nicely tells us which function)
claims it's using INTB, but ACPI isn't telling us which GSI that
corresponds to.  Can you ask your BIOS guys about this?
Comment 2 Len Brown 2003-12-03 17:42:57 UTC
2.6 tries to derive an IRQ -- but fails:
 pci_irq-0302 [03] acpi_pci_irq_derive   : Unable to derive IRQ for device 
0000:00:03.3
ACPI: No IRQ known for interrupt pin B of device 0000:00:03.3

2.4 lspci:
00:03.3 SMBus: Intel Corp. 82372FB PIIX5 SMBus (rev 01)
	Subsystem: Intel Corp.: Unknown device 414c
	Flags: medium devsel
	I/O ports at c000 [disabled] [size=16]

This looks like a firmware bug ragther than an ACPI bug -- closing.
Comment 3 Andre Pletschette 2003-12-08 11:08:30 UTC
test
Comment 4 Luming Yu 2003-12-10 02:31:40 UTC
There is only 1 PRT entry in DSDT for bus 0, slot 3,  but it is for pin D  not 
for pin B . And the error message reflect that fact. 
This error is for device 00:03.3 --SMBus. I don't know how to test that device.
Actually 2.6 will call acpi_pci_irq_derive try to derive IRQ from parent 
bridge, if nothing found from PRT List, But 2.4 will not do that.
Actually, acpi_pci_irq_enable will not be called in 2.4. Maybe this is a issue. 
But it will not help this case.

                Package (0x04)
                {
                    0x0003FFFF, 
                    0x03, 
                    0x00, 
                    0x32
                }, 
Comment 5 Luming Yu 2003-12-10 02:37:06 UTC
Created attachment 1652 [details]
DSDT
Comment 6 Len Brown 2005-08-17 14:55:53 UTC
luming, is this still an issue?
Comment 7 Luming Yu 2005-08-21 19:39:43 UTC
I don't have access to this Lion box.  
I colse it as unperoducibile. 
If someone else find it again, please reopen it. 
 
Thanks, 
Luming 

Note You need to log in before you can comment on or make changes to this bug.