Bug 15336 - PS/2 mouse driver is faulty
PS/2 mouse driver is faulty
Status: RESOLVED DUPLICATE of bug 6105
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-17 04:44 UTC by nbi
Modified: 2010-02-17 06:44 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments

Description nbi 2010-02-17 04:44:45 UTC
When my PS/2 mouse is connected via the motherboard's PS/2 connector the pointer goes crazy at times racing around the screen and randomly opening/closing windows. This can happen several times per day. This behavior is accompanied by the following in /var/log/messages:

psmouse.c: bad data from KBC - bad parity
psmouse.c: Mouse at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.

I have ruled out that this is a hardware problem. How? There are no such problems under any MS Windows variant on the same platform. More importantly when I connect the same mouse to the PC via a PS2<->USB adapter there are no problems. If the mouse HW is the culprit then one should see some evidence to that effect in either or both MS Windows and the USB configuration. The evidence suggests that psmouse.c or related code is at fault. It seems mouse signals are not handled by the same code when connected via USB.
Comment 1 Dmitry Torokhov 2010-02-17 06:44:43 UTC

*** This bug has been marked as a duplicate of bug 6105 ***

Note You need to log in before you can comment on or make changes to this bug.