Bug 15333 - /sys/module/usb_storage missing
/sys/module/usb_storage missing
Status: RESOLVED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 high
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-17 01:44 UTC by Barry Kauler
Modified: 2010-02-17 07:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc8
Tree: Mainline
Regression: Yes


Attachments

Description Barry Kauler 2010-02-17 01:44:10 UTC
I am testing 2.6.33-rc8 in Puppy Linux.

The usb_storage module is loaded, and it works. 

However there is no /sys/module/usb_storage directory.

That seems very wrong. There should be a directory in /sys/module for all loaded modules.
Comment 1 Andrew Morton 2010-02-17 04:59:49 UTC
That's weird.  Do all other modules appear there?
Comment 2 Greg Kroah-Hartman 2010-02-17 05:34:11 UTC
On Wed, Feb 17, 2010 at 01:44:11AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
> However there is no /sys/module/usb_storage directory.
> 
> That seems very wrong. There should be a directory in /sys/module for all
> loaded modules.

I agree, this should be present, are you sure you actually built
this module?  I see it on my machines.
Comment 3 Barry Kauler 2010-02-17 07:48:25 UTC
Oh dear, this is very embarrassing.

It turns out to be a cache problem with ROX-Filer, my file manager. I don't know why, haven't had this problem before. Normally, mouse-over or click in a ROX window causes it to rescan, but for some reason it was not doing so when I had the /sys/module window open.

I'm very sorry for wasting your time, please close this bug.

Regards,
Barry Kauler
Comment 4 Barry Kauler 2010-02-17 07:49:45 UTC
I guess I can mark it as resolved/invalid.

Note You need to log in before you can comment on or make changes to this bug.