Bug 15286 - Cannot change brightness with Intel Arrandale on Sony VPCS111FM laptop
Cannot change brightness with Intel Arrandale on Sony VPCS111FM laptop
Status: CLOSED DUPLICATE of bug 15279
Product: ACPI
Classification: Unclassified
Component: Power-Video
All Linux
: P1 normal
Assigned To: acpi_power-video
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-02-12 15:22 UTC by Armando Di Cianno
Modified: 2010-04-03 22:59 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.8
Tree: Mainline
Regression: No


Attachments
tar'd bzip of various items of output that will be requested (21.26 KB, application/octet-stream)
2010-02-12 15:22 UTC, Armando Di Cianno
Details

Description Armando Di Cianno 2010-02-12 15:22:36 UTC
Created attachment 25008 [details]
tar'd bzip of various items of output that will be requested

Same results in kernels:
* 2.6.32.8 vanilla
* gentoo-sources-2.6.32-r4 (above + gentoo patches)

All tests in attached output from vanilla kernel.

I have searched for similar bug reports, and didn't find anything that helped.  I have attached a tar'd bzip of all debug information I've collected that seemed to be asked in other similar reports.
--> Contents of tar:
dsdt.bin
lspci-tv.output
nomodeset-find_proc_acpi.output
nomodeset-find_sys_class_backlight.output
vendor-find_proc_acpi.output
vendor-find_sys_class_backlight.output
vendor-find_sys_class_backlight_sony.output
vendor-manual_attempt_to_change_brightness.session
vendor-xbacklight_attempts.session
video-find_proc_acpi.output
video-find_sys_class_backlight.output
video-xbacklight_attempts.session

I have a fairly new Sony VPCS111FM.  It's pretty much an Intel-everything laptop.
--> see lspci-tv.output

I cannot change the laptop brightness.  From what I can tell, it looks like Kernel Mode Setting is required (?) on this machine/chipset to get X started, as I get a blank/black screen w/o KMS (using xf86-video-intel-2.9.1).

I have attempted to use the kernel parameter "acpi_brightness" set to either 'vendor' or 'video', and have attached various outputs that show the contents of /proc/acpi and /sys/class/backlight under both cases.  'vendor' gets me further, as the 'sony' directory and subentries appear in /sys/class/backlight, but they do not change the physical appear of the brightness of the screen.  When in 'vendor' mode, neither xbacklight nor xrandr (for brightness) works.
--> see vendor-*

I have also attached a binary DSDT dump.
--> see dsdt.bin

I'm happy to try anything, as I'm completely at a loss after much debugging and trial and error.
Comment 1 Armando Di Cianno 2010-02-12 15:27:35 UTC

*** This bug has been marked as a duplicate of bug 15279 ***

Note You need to log in before you can comment on or make changes to this bug.