Bug 15279 - Cannot change brightness with Intel Arrandale on Sony VPCS111FM laptop
Summary: Cannot change brightness with Intel Arrandale on Sony VPCS111FM laptop
Status: CLOSED PATCH_ALREADY_AVAILABLE
Alias: None
Product: ACPI
Classification: Unclassified
Component: Power-Video (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: acpi_power-video
URL:
Keywords:
: 15280 15286 (view as bug list)
Depends on:
Blocks:
 
Reported: 2010-02-11 22:05 UTC by Armando Di Cianno
Modified: 2010-09-29 02:28 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.8
Tree: Mainline
Regression: No


Attachments

Description Armando Di Cianno 2010-02-11 22:05:03 UTC
Same results in kernels:
* 2.6.32.8 vanilla
* gentoo-sources-2.6.32-r4 (above + gentoo patches)

All tests in attached output from vanilla kernel.

I have searched for similar bug reports, and didn't find anything that helped.  I have attached a tar'd bzip of all debug information I've collected that seemed to be asked in other similar reports.
--> Contents of tar:
dsdt.bin
lspci-tv.output
nomodeset-find_proc_acpi.output
nomodeset-find_sys_class_backlight.output
vendor-find_proc_acpi.output
vendor-find_sys_class_backlight.output
vendor-find_sys_class_backlight_sony.output
vendor-manual_attempt_to_change_brightness.session
vendor-xbacklight_attempts.session
video-find_proc_acpi.output
video-find_sys_class_backlight.output
video-xbacklight_attempts.session

I have a fairly new Sony VPCS111FM.  It's pretty much an Intel-everything laptop.
--> see lspci-tv.output

I cannot change the laptop brightness.  From what I can tell, it looks like Kernel Mode Setting is required (?) on this machine/chipset to get X started, as I get a blank/black screen w/o KMS (using xf86-video-intel-2.9.1).

I have attempted to use the kernel parameter "acpi_brightness" set to either 'vendor' or 'video', and have attached various outputs that show the contents of /proc/acpi and /sys/class/backlight under both cases.  'vendor' gets me further, as the 'sony' directory and subentries appear in /sys/class/backlight, but they do not change the physical appear of the brightness of the screen.
--> see vendor-*

I have also attached a binary DSDT dump.
--> see dsdt.bin

I'm happy to try anything, as I'm completely at a loss after much debugging and trial and error.
Comment 1 Armando Di Cianno 2010-02-12 15:27:35 UTC
*** Bug 15286 has been marked as a duplicate of this bug. ***
Comment 2 Armando Di Cianno 2010-02-12 15:27:58 UTC
*** Bug 15280 has been marked as a duplicate of this bug. ***
Comment 3 Armando Di Cianno 2010-02-12 15:28:54 UTC
Sorry about the barrage of duplicates -- not sure how that happened.
Comment 4 Armando Di Cianno 2010-02-13 15:52:51 UTC
dmesg portion that seems relevant (kms, acpi_brightness="video")

[    0.000000] Using ACPI (MADT) for SMP configuration information
[    0.000000] ACPI: HPET id: 0x8086a201 base: 0xfed00000
[    0.001857] ACPI: Core revision 20090903
[    0.938724] ACPI FADT declares the system doesn't support PCIe ASPM, so disable it
[    0.938830] ACPI: bus type pci registered
[    0.952032] ACPI: EC: Look up EC in DSDT
[    0.952097] ACPI Error: No handler for Region [ERAM] (ffff880137861738) [EmbeddedControl] (20090903/evregion-319)
[    0.952279] ACPI Error: Region EmbeddedControl(3) has no handler (20090903/exfldio-295)
[    0.952455] ACPI Error (psparse-0537): Method parse/execution failed [\_SB_.PCI0.DOCK._STA] (Node ffff88013785c9b0), AE_NOT_EXIST
[    0.952716] ACPI Error (uteval-0250): Method execution failed [\_SB_.PCI0.DOCK._STA] (Node ffff88013785c9b0), AE_NOT_EXIST
[    0.953808] ACPI: Executed 1 blocks of module-level executable AML code
[    0.957817] ACPI: BIOS _OSI(Linux) query ignored
[    1.559923] ACPI: Interpreter enabled
[    1.559996] ACPI: (supports S0 S3 S4 S5)
[    1.560230] ACPI: Using IOAPIC for interrupt routing
[    1.562175] [Firmware Bug]: ACPI: ACPI brightness control misses _BQC function
[    1.571444] ACPI: EC: GPE = 0x16, I/O: command/status = 0x66, data = 0x62
[    1.575026] ACPI: ACPI Dock Station Driver: 1 docks/bays found
Comment 5 Armando Di Cianno 2010-02-14 19:53:55 UTC
vanilla 2.6.33-rc7 solved this issue for me.

Of note, is that acpi_backlight set to vendor or video acts the same now:
* `xbacklight -set FOO` works
* `xrandr --output LVDS1 --prop` returns nothing, so stuff like `xrandr --output LVDS1 --set BACKLIGHT_CONTROL native` does not work

I'd be curious as to why xbacklight works, and xrandr not, but no matter.  Closing this bug.
Comment 6 Len Brown 2010-09-29 02:28:21 UTC
> vanilla 2.6.33-rc7 solved this issue for me.

closed

Note You need to log in before you can comment on or make changes to this bug.