Bug 15261 - Static electricity build up with 2.6.32
Static electricity build up with 2.6.32
Status: CLOSED UNREPRODUCIBLE
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 normal
Assigned To: power-management_other
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-02-09 13:33 UTC by Kevin
Modified: 2012-05-14 14:58 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
Hardware info (26.93 KB, text/plain)
2010-02-09 13:33 UTC, Kevin
Details
dmesg (50.96 KB, text/plain)
2010-02-09 13:34 UTC, Kevin
Details

Description Kevin 2010-02-09 13:33:07 UTC
Created attachment 24970 [details]
Hardware info

When I first compiled the 2.6.32 kernel when it was rc5, I had problems with my box booting. The problem it turns out was static build up in my laptop. After every suspend or third reboot, my computer refuses to turn on because of the static. I then have to pull out the battery and put my finger on the power button to draw  the static away.

I'm not sure how the 2.6.32 kernel is causing/failing to prevent this, but it has been a repeating problem  with the 2.6.32 kernel, across several distributions, both stock and custom made.
Comment 1 Kevin 2010-02-09 13:34:42 UTC
Created attachment 24971 [details]
dmesg
Comment 2 Rafael J. Wysocki 2010-02-09 19:56:55 UTC
Did 2.6.31 work correctly?
Comment 3 Kevin 2010-02-09 20:17:36 UTC
(In reply to comment #2)
> Did 2.6.31 work correctly?

Yes. I've ran kernel 2.6.26-2.6.31 on this box, all worked fine. 2.6.32 is the first to do this.
Comment 4 Kevin 2010-02-20 00:22:36 UTC
I'm starting to think the problem is KMS. I'm running a .30 kernel with it enabled, and it's giving me the same fits. However, I get a message whenever I drop out of X when the computer has too much static. It reads "ACPI:EC:input buffer is not empty, aborting transaction"

No idea what it means, but when it shows up, my computer won't start after a reboot without dissipating the static built up.
Comment 5 Rafael J. Wysocki 2011-01-16 22:17:30 UTC
Is the problem still present in 2.6.37?
Comment 6 Mark Luntzel 2011-01-26 23:46:49 UTC
http://pics.livejournal.com/adgy/pic/0084yqe0
Comment 7 Zhang Rui 2012-01-18 01:57:53 UTC
It's great that kernel bugzilla is back.

can you please verify if the problem still exists in the latest upstream
kernel?

Note You need to log in before you can comment on or make changes to this bug.