Bug 15247 - [2.6.33-rc5] tty: possible irq lock inversion dependency in tty_fasync
[2.6.33-rc5] tty: possible irq lock inversion dependency in tty_fasync
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: drivers_other
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-02-07 09:09 UTC by Maciej Rutecki
Modified: 2010-02-07 21:09 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-02-07 09:09:03 UTC
Subject    : [2.6.33-rc5] tty: possible irq lock inversion dependency in tty_fasync
Submitter  : Tetsuo Handa <penguin-kernel@I-love.SAKURA.ne.jp>
Date       : 2010-02-07 5:52
References : http://marc.info/?l=linux-kernel&m=126552198328604&w=2
Handled-By :
First-Bad-Commit : http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commit;h=703625118069f9f8960d356676662d3db5a9d116

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Maciej Rutecki 2010-02-07 09:19:35 UTC
Patch : http://marc.info/?l=linux-kernel&m=126552522830403&w=2
Comment 2 Rafael J. Wysocki 2010-02-07 09:50:52 UTC
Handled-By : Linus Torvalds <torvalds@linux-foundation.org>

Caused by:

commit 703625118069f9f8960d356676662d3db5a9d116
Author: Greg Kroah-Hartman <gregkh@suse.de>
Date:   Thu Dec 17 07:07:19 2009 -0800

    tty: fix race in tty_fasync

    Signed-off-by: Greg Kroah-Hartman <gregkh@suse.de>

Fitst-Bad-Commit : 703625118069f9f8960d356676662d3db5a9d116

Note You need to log in before you can comment on or make changes to this bug.