Bug 15245 - [2.6.33-rc6 Weird JCPU times?
Summary: [2.6.33-rc6 Weird JCPU times?
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Process Management
Classification: Unclassified
Component: Other (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: process_other
URL:
Keywords:
Depends on:
Blocks: 14885
  Show dependency tree
 
Reported: 2010-02-07 08:29 UTC by Maciej Rutecki
Modified: 2011-05-03 20:59 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.33-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Maciej Rutecki 2010-02-07 08:29:43 UTC
Subject    : [2.6.33-rc6 fc76be4 w/ drm-radon-testing and KMS enabled] Weird JCPU times?
Submitter  : Shawn Starr <shawn.starr@rogers.com>
Date       : 2010-02-06 7:24
References : http://marc.info/?l=linux-kernel&m=126544107816889&w=2

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Shawn Starr 2010-02-07 20:04:34 UTC
This is reproducible with non-KMS also, -rc7 has not seen this yet. But I still haven't stressed -rc7 enough.
Comment 2 Jérôme Glisse 2010-02-11 14:00:30 UTC
I don't this is a regression, Shawn you did merge by yourself radeon-testing right ? So this isn't a natural 2.6.33-rc* kernel. Please confirm if you see this or not with a stock 2.6.33-rc*.

Also i wonder how kms can affect jcpu ...
Comment 3 Shawn Starr 2010-02-12 18:18:28 UTC
I can confirm this is not due to Radeon as im using the intel GPU and see

spstarr   6085 7696761  0.0 18992 2024 pts/6   Ss   12:57 21114581:29 /bin/bash
spstarr   6092 152211946  0.0 18936 1364 pts/6 S+   12:58 21114581:29 top


It seems to be a real kernel regression.

As of 2.6.33-rc7 last night's linus's tree still.
Comment 4 Shawn Starr 2010-02-12 18:21:32 UTC
We should rename this to drop references to radeon as it is not related.
Comment 5 Rafael J. Wysocki 2010-03-21 21:28:38 UTC
On Sunday 21 March 2010, Shawn Starr wrote:
> On Sunday 21 March 2010 04:30:46 pm Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of regressions introduced between 2.6.32 and 2.6.33.
> > 
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.32 and 2.6.33.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=15245
> > Subject             : [2.6.33-rc6 Weird JCPU times?
> > Submitter   : Shawn Starr <shawn.starr@rogers.com>
> > Date                : 2010-02-06 7:24 (44 days old)
> > References  : http://marc.info/?l=linux-kernel&m=126544107816889&w=2
> 
> Please close it. I haven't seen this anymore and I'm now in 2.6.34-rc1 (March 
> 17th git snapshot)
Comment 6 Stefan 2011-05-03 20:57:57 UTC
With 2.6.32.36 x86_64 I can reproduce these CPU times by running latencytop 0.4 for a few seconds.
Comment 7 Stefan 2011-05-03 20:59:16 UTC
# ps aux|head
USER       PID %CPU %MEM    VSZ   RSS TTY      STAT START   TIME COMMAND
root         1 40993630  0.0 1068 392 ?        Ss   10:28 21114581:29 init [5]  
root         2 40993630  0.0  0     0 ?        S    10:28 21114581:29 [kthreadd]
root         3 40993666  0.0  0     0 ?        S    10:28 21114581:29 [migration/0]
root         4 40993675  0.0  0     0 ?        S    10:28 21114581:29 [ksoftirqd/0]
root         7 40993766  0.0  0     0 ?        S    10:28 21114581:29 [events/0]
root         9  0.0  0.0      0     0 ?        S    10:28   0:00 [cpuset]
root        10  0.0  0.0      0     0 ?        S    10:28   0:00 [khelper]
root        11  0.0  0.0      0     0 ?        S    10:28   0:00 [async/mgr]

Note You need to log in before you can comment on or make changes to this bug.