Bug 15242 - Kernel won't boot with acpi in virtualbox
Kernel won't boot with acpi in virtualbox
Status: CLOSED INVALID
Product: ACPI
Classification: Unclassified
Component: Config-Other
All Linux
: P1 normal
Assigned To: acpi_config-other
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-02-06 23:02 UTC by Martin Erik Werner
Modified: 2010-02-10 23:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.32.4
Tree: Mainline
Regression: Yes


Attachments

Description Martin Erik Werner 2010-02-06 23:02:36 UTC
Original bug reported on launchpad: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/510571

Kernels past a specific version won't boot along with acpi in virtualbox

Boot hangs at either "Checking 'hlt' instruction... OK."
OR "SMP alternatives: switching to UP code"
(at which point virtualbox uses close to 100% cpu also)

Booting with the acpi=off flag, or disabling acpi in virtualbox allows normal boot.

version 2.6.32-10.14 (ubuntu)
based on 2.6.32.2, works fine

version 2.6.32-11-15 (ubuntu)
based on 2.6.32.4
is the first to exhibit the issue

along with later
version 2.6.33-999.201001191335 (ubuntu mainline daily)
based on long<v2.6.33-rc4-399-g24bc734>
commit 24bc7347da73a9ed3383056c3d0f28c0e361621e

and
version 2.6.33-999.201002061003 (ubuntu mainline daily)
based on: long<v2.6.33-rc6-228-g56dca4c>
commit 56dca4ceb7b39aa4173aa1cb822c860ced2be1ec

...which fails similarly.
Comment 1 Martin Erik Werner 2010-02-10 23:00:16 UTC
According to comments on the launchpad bug, this seems to be a problem in virtualbox rather. Closing.

Note You need to log in before you can comment on or make changes to this bug.