Bug 15237 - Suspend/hibernate locks up with X active
Suspend/hibernate locks up with X active
Status: RESOLVED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216
  Show dependency treegraph
 
Reported: 2010-02-06 03:02 UTC by Ryan Underwood
Modified: 2010-08-03 18:58 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.31, 2.6.32
Tree: Mainline
Regression: Yes


Attachments
pm-suspend.log (49.54 KB, text/plain)
2010-02-06 03:02 UTC, Ryan Underwood
Details
lspci -vvvn (24.35 KB, text/plain)
2010-02-06 03:02 UTC, Ryan Underwood
Details
dmidecode (8.70 KB, text/plain)
2010-02-06 03:03 UTC, Ryan Underwood
Details
Xorg.log (35.48 KB, application/octet-stream)
2010-02-06 03:03 UTC, Ryan Underwood
Details
lspci -vv (15.17 KB, text/plain)
2010-02-06 21:15 UTC, Ryan Underwood
Details
lspci -vv (21.12 KB, text/plain)
2010-03-07 00:48 UTC, arond
Details

Description Ryan Underwood 2010-02-06 03:02:14 UTC
Created attachment 24922 [details]
pm-suspend.log

I have used suspend/hibernate in the past, but not for a while.

This is an HP DV2910US laptop with Intel 965 chipset.

I can suspend/hibernate apparently all day long when booted to a recovery console (X not active).

As soon as X is then activated (startx), suspend/hibernate becomes broken.  It seems to do all the work required to suspend (including switching VT with s2ram).  But at the instant when the machine would feel like it would normally suspend or power off, instead it totally hangs with no further activity.

If I boot into X and do not try to suspend from the console beforehand, I can suspend/hibernate precisely once per session.  The second attempt will produce the above behavior.

The machine has the latest BIOS from HP and I am running Ubuntu Karmic with some packages pulled in from Lucid.
Comment 1 Ryan Underwood 2010-02-06 03:02:53 UTC
Created attachment 24923 [details]
lspci -vvvn
Comment 2 Ryan Underwood 2010-02-06 03:03:25 UTC
Created attachment 24924 [details]
dmidecode
Comment 3 Ryan Underwood 2010-02-06 03:03:49 UTC
Created attachment 24925 [details]
Xorg.log
Comment 4 Rafael J. Wysocki 2010-02-06 19:34:37 UTC
1. Please attach the output of "lspci -vv".

2. What kind of graphics adapter is there in the box?

3. Have you upgraded X recently?

4. What was the last working kernel?
Comment 5 Ryan Underwood 2010-02-06 21:14:40 UTC
1. attached
2. Intel 965 (also tried with nomodeset)
3. Yes, from karmic to lucid packages, but it didn't solve the problem
4. If I had to make a guess I'd say it was 2.6.30 or prior.
Comment 6 Ryan Underwood 2010-02-06 21:15:17 UTC
Created attachment 24929 [details]
lspci -vv
Comment 7 Andrew Morton 2010-02-08 21:39:35 UTC
Methinks this should be reassigned to DRI.  Rafael, I'll assume that you'll take care of this, if needed.
Comment 8 Rafael J. Wysocki 2010-02-08 21:59:04 UTC
Agreed, so reassigning.
Comment 9 Jesse Barnes 2010-02-19 20:50:37 UTC
Can you try the drm-intel-next branch from git://git.kernel.org/pub/scm/linux/kernel/git/anholt/drm-intel?

Also, please try using echo mem > /sys/power/state from a xterm or something to isolate any pm-suspend related funkiness.
Comment 10 Ryan Underwood 2010-02-25 14:36:41 UTC
I tried drm-intel-next, but got a blank display at boot and thereafter unless 'nomodeset' was passed.  Using nomodeset, the same suspend/resume problem persisted with that kernel.  I did the suspend via /sys/power/state directly.
Comment 11 Jesse Barnes 2010-02-26 22:53:40 UTC
Make sure you have CONFIG_FRAMEBUFFER_CONSOLE=y in your kernel config or you'll get a blank display.  Also you'll need a recent version of xf86-video-intel (2.8 at least I think) to work with the new KMS bits.
Comment 12 Ryan Underwood 2010-03-03 18:29:35 UTC
I have it enabled and still get a blank display at bootup with that kernel.
Comment 13 Ryan Underwood 2010-03-03 18:30:17 UTC
xserver-xorg-video-intel is 2.9.1 (Ubuntu)
Comment 14 arond 2010-03-07 00:46:56 UTC
Hi,

I think i can confirm this bug. I have a Intel 945GME. I'm running 2.6.33-29-pae on a opensuse 11.1 box with the intel drivers 2.10.0 and Xorg 1.7.5

I can also say that the problem wasn't there on 2.6.32-39 but I'm not sure when exactly it appeared.

Also, the first time i noticed suspend to disk just froze when running X. Then there was some versions in which it would just work once. On the my current kernel it is back to the initial behaviour (freezing on first try).

I will attach lspci -vv now. If there's any other way i can contribute just tell!
Comment 15 arond 2010-03-07 00:48:09 UTC
Created attachment 25391 [details]
lspci -vv
Comment 16 Ryan Underwood 2010-05-24 23:25:50 UTC
No longer a bug in 2.6.34.  However, I am still unable to get display at boot with KMS active.
Comment 17 Jesse Barnes 2010-07-02 23:22:07 UTC
Do you still see the blank display problem?  Even with a stock ubuntu kernel from the xorg edgers repo?
Comment 18 Ryan Underwood 2010-07-19 13:52:11 UTC
Still blank with 2.6.34.1 from kernel.org (using ubuntu kernel config).
Comment 19 Jesse Barnes 2010-07-19 16:17:23 UTC
Does VT switch also cause a blank screen?  If so, this could be an X problem I fixed recently.  xorg edgers should have a fixed package.
Comment 20 Ryan Underwood 2010-07-20 16:53:33 UTC
X VT switch works fine.  KMS still gives me a blank screen at boot necessitating  'nomodeset'.
Comment 21 Jesse Barnes 2010-07-20 17:02:28 UTC
Can you file a new bug at bugs.freedesktop.org for the blank screen problem?  http://intellinuxgraphics.org/how_to_report_bug.html has info on which files we need.  In particular, I'd like to see the boot log from a fresh boot (before X starts) with debug=4 (the drm module option).

Thanks,
Jesse
Comment 22 Ryan Underwood 2010-08-03 18:49:00 UTC
2.6.35 put an end to the KMS issue finally.  Mode setting at boot is working correctly now.
Comment 23 Jesse Barnes 2010-08-03 18:58:46 UTC
Cool, thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.