Bug 152111 - [sparc64] btrfs module fails to load on big-endian machines
Summary: [sparc64] btrfs module fails to load on big-endian machines
Status: RESOLVED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: btrfs (show other bugs)
Hardware: Sparc64 Linux
: P1 blocking
Assignee: Josef Bacik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-08-12 12:15 UTC by Anatoly Pugachev
Modified: 2017-01-16 11:59 UTC (History)
0 users

See Also:
Kernel Version: v4.8-rc7+
Tree: Mainline
Regression: No


Attachments

Description Anatoly Pugachev 2016-08-12 12:15:31 UTC
Hello!

Btrfs fails to load on my SPARC T5-2 if kernel (git describe v4.8-rc1-121-g4b9eaf3) compiled with:

CONFIG_BTRFS_FS=m
CONFIG_BTRFS_FS_POSIX_ACL=y
CONFIG_BTRFS_FS_CHECK_INTEGRITY=y
CONFIG_BTRFS_FS_RUN_SANITY_TESTS=y
CONFIG_BTRFS_DEBUG=y
CONFIG_BTRFS_ASSERT=y

It fails to load with the following messages:

[935325.023060] Btrfs loaded, crc32c=crc32c-generic, debug=on, assert=on, integrity-checker=on
[935325.126569] BTRFS: selftest: sectorsize: 8192  nodesize: 8192
[935325.198669] BTRFS: selftest: Running btrfs free space cache tests
[935325.275501] BTRFS: selftest: Running extent only tests
[935325.340189] BTRFS: selftest: Running bitmap only tests
[935325.405362] BTRFS: selftest: Running bitmap and extent tests
[935325.477392] BTRFS: selftest: Running space stealing from bitmap to extent
[935325.565969] BTRFS: selftest: Free space cache tests finished
[935325.637002] BTRFS: selftest: Running extent buffer operation tests
[935325.637006] BTRFS: selftest: Running btrfs_split_item tests
[935325.637540] BTRFS: selftest: Running extent I/O tests
[935325.637543] BTRFS: selftest: Running find delalloc tests
[935325.912633] BTRFS: selftest: Running extent buffer bitmap tests
[935325.916466] BTRFS: selftest: Setting straddling pages failed
[935325.916490] BTRFS: selftest: Extent I/O tests finished

I have reported it in [1] and there's a patch [2] for v4.7-rc7 kernel, but it does not applies cleanly to current git kernel.

I've made some btrfs fs tests (using xfstests suite) after applying [2] patch with 4.7-rc7 kernel and tests run successfully (i.e. with ok result, without errors).

Can someone refresh patch in [2] to support current git kernel and push it to git?
 
Thanks.

[1]. http://www.spinics.net/lists/linux-btrfs/msg56964.html
[2]. http://www.spinics.net/lists/linux-btrfs/msg57193.html
Comment 1 Anatoly Pugachev 2016-09-09 12:55:15 UTC
still valid for v4.8-rc5+
Comment 2 Anatoly Pugachev 2016-09-22 13:21:05 UTC
proposed to be fixed in 4.9 or 4.10

https://marc.info/?l=linux-btrfs&m=147447935830006&w=2
Comment 3 Anatoly Pugachev 2017-01-16 11:59:58 UTC
Can't reproduce on 4.10.0-rc4 , closing as resolved.

Note You need to log in before you can comment on or make changes to this bug.