Bug 15207 - Pineview - only cursor on black screen visible, "GPU hung" in dmesg
Pineview - only cursor on black screen visible, "GPU hung" in dmesg
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 blocking
Assigned To: Shaohua
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-02-01 20:15 UTC by Christian Friedemann
Modified: 2010-02-21 21:21 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33-rc7
Tree: Mainline
Regression: Yes


Attachments
kernel .config (86.32 KB, text/plain)
2010-02-01 20:15 UTC, Christian Friedemann
Details
dmesg (45.89 KB, text/plain)
2010-02-01 20:15 UTC, Christian Friedemann
Details
lsmod (443 bytes, text/plain)
2010-02-01 20:16 UTC, Christian Friedemann
Details
lspci (22.20 KB, text/plain)
2010-02-01 20:16 UTC, Christian Friedemann
Details
xorg log (26.59 KB, text/plain)
2010-02-01 20:17 UTC, Christian Friedemann
Details
dmesg 2.6.33-rc7-git2 (2.22 KB, text/plain)
2010-02-10 14:01 UTC, Christian Friedemann
Details

Description Christian Friedemann 2010-02-01 20:15:01 UTC
Created attachment 24854 [details]
kernel .config

Impossible to start X with 2.6.33rc kernel, because there is nothing on the screen except the cursor. The cursor changes if you get over an icon(or better: the place where it should be).
Switching to tty works.

[drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
render error detected, EIR: 0x00000000

Compiling 2.6.32.* kernel with exactly the same settings works just fine.

Xorg log, output of dmesg, lspci -vxxx and lsmod and my kernel .config are attached.
Comment 1 Christian Friedemann 2010-02-01 20:15:49 UTC
Created attachment 24855 [details]
dmesg
Comment 2 Christian Friedemann 2010-02-01 20:16:12 UTC
Created attachment 24856 [details]
lsmod
Comment 3 Christian Friedemann 2010-02-01 20:16:34 UTC
Created attachment 24857 [details]
lspci
Comment 4 Christian Friedemann 2010-02-01 20:17:00 UTC
Created attachment 24858 [details]
xorg log
Comment 5 Andrew Morton 2010-02-01 20:33:43 UTC
Marked as a regression.
Comment 6 Gordon Jin 2010-02-09 09:04:55 UTC
This should have been fixed in 2.6.33-rc7 with:

commit 8a6c77d645d9111f7bc01f908464301f5c3e0a05
Author: Li Peng <peng.li@linux.intel.com>
Date:   Thu Jan 21 18:45:46 2010 +0800

    drm/i915: Fix the device info of Pineview

    Pineview doesn't has CXSR and need GTT-based hardware status page.
    It fixes a X boot hung issue on Pinview since commit cfdf1f


More details in http://bugs.freedesktop.org/show_bug.cgi?id=26439.
Comment 7 Christian Friedemann 2010-02-10 13:57:21 UTC
Problem is not solved on Kernel 2.6.33-rc7-git2 for me.
Neither can I start X nor am I able to switch to tty after xinit.
There is no cursor anymore, only a black screen.
Loading the i915 module manually causes a segfault.

I will an attachment with dmesg error.
Comment 8 Christian Friedemann 2010-02-10 14:01:04 UTC
Created attachment 24988 [details]
dmesg 2.6.33-rc7-git2

Relevant part of dmesg.
Comment 9 Jesse Barnes 2010-02-19 20:52:38 UTC
Shaohua, can you take a look?
Comment 10 Christian Friedemann 2010-02-19 21:02:00 UTC
Wanted to write it yesterday, but there was a mysql problem with filezilla.

Problem fixed in 2.6.33-rc8.

Note You need to log in before you can comment on or make changes to this bug.