Bug 15205 - blank screen with KMS if lid is closed before kernel boots
blank screen with KMS if lid is closed before kernel boots
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: ykzhao
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2010-02-01 09:08 UTC by Sven Joachim
Modified: 2010-03-25 02:21 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.32.7, 2.6.33-rc6
Tree: Mainline
Regression: Yes


Attachments
dmidecode output (6.76 KB, text/plain)
2010-02-08 11:05 UTC, Sven Joachim
Details
try the patch that adds Acer travelmate 2490 to ACPI LID quirk list (883 bytes, patch)
2010-02-22 06:27 UTC, ykzhao
Details | Diff

Description Sven Joachim 2010-02-01 09:08:46 UTC
I'm using a laptop with Intel 945 graphics and KMS enabled (i915 driver loaded from initramfs).  If I close the lid before the kernel boots, the screen stays blank (backlight appears to be off) after opening the lid and remains so until a reboot, suspending and resuming does not help.

This appears to be a regression, as the problem does not exist in 2.6.31.12.
Comment 1 Sven Joachim 2010-02-01 13:24:04 UTC
Bisecting shows that commit b42d4c5c6a872815d711e5d51a600f5122c38eee was the first "bad" one:

commit b42d4c5c6a872815d711e5d51a600f5122c38eee
Author: Jesse Barnes <jbarnes@virtuousgeek.org>
Date:   Thu Sep 10 15:28:04 2009 -0700

 drm/i915: use ACPI LID status for LVDS ->detect hook
    
 We can't load or hotplug detect LVDS like we can other outputs, but if
 there's a lid device present we can use it as a proxy.  This allows the
 LFP state to be determined at ->detect time, making configurations
 requiring manual intervention today "just work" assuming the lid device
 status is correct.
    
 Signed-off-by: Jesse Barnes <jbarnes@virtuousgeek.org>
 Signed-off-by: Eric Anholt <eric@anholt.net>
Comment 2 Rafael J. Wysocki 2010-02-01 22:24:57 UTC
First-Bad-Commit : b42d4c5c6a872815d711e5d51a600f5122c38eee
Comment 3 Jesse Barnes 2010-02-05 21:34:47 UTC
We may need a lid quirk for this platform.  Yakui can you take a look?
Comment 4 ykzhao 2010-02-08 08:39:46 UTC
Will you please attach the output of dmidecode on this box?

thanks.
Comment 5 Sven Joachim 2010-02-08 11:05:29 UTC
Created attachment 24952 [details]
dmidecode output
Comment 6 Jesse Barnes 2010-02-19 20:34:57 UTC
This one may be fixed by the load detect fix (should be in stable and for-linus soon).  If not we can add a quirk.
Comment 7 ykzhao 2010-02-22 06:27:21 UTC
Created attachment 25156 [details]
try the patch that adds Acer travelmate 2490 to ACPI LID quirk list

Will you please try this patch and see whether it can work for you?

thanks.
Comment 8 Sven Joachim 2010-02-22 10:36:39 UTC
The patch works for me, thanks.
Comment 9 ykzhao 2010-03-25 02:21:59 UTC
Now the mechanism of LVDS detection by using LID status is abandoned in the following commit:
   >commit 6e6c822868f113dabe3c33bdd91e883cc28fa11b
Author: Eric Anholt <eric@anholt.net>
Date:   Wed Mar 17 13:48:06 2010 -0700

    drm/i915: Stop trying to use ACPI lid status to determine LVDS connection.

And this bug on this box can be fixed by this commit.

So this bug will be marked as resolved.

thanks.

Note You need to log in before you can comment on or make changes to this bug.