Bug 15202 - lockdep warning during elevator_switch
Summary: lockdep warning during elevator_switch
Status: CLOSED CODE_FIX
Alias: None
Product: File System
Classification: Unclassified
Component: SysFS (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks: 14885
  Show dependency tree
 
Reported: 2010-02-01 00:24 UTC by Rafael J. Wysocki
Modified: 2010-03-22 21:27 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc3
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-02-01 00:24:34 UTC
Subject    : lockdep warning during elevator_switch
Submitter  : Hugh Dickins <hugh.dickins@tiscali.co.uk>
Date       : 2010-01-31 23:55
References : http://marc.info/?l=linux-kernel&m=126498212613051&w=4

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-02-08 00:11:00 UTC
On Monday 08 February 2010, Hugh Dickins wrote:
> On Sun, 7 Feb 2010, Rafael J. Wysocki wrote:
> 
> > This message has been generated automatically as a part of a summary report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let the
> tracking team
> > know (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=15202
> > Subject             : lockdep warning during elevator_switch
> > Submitter   : Hugh Dickins <hugh.dickins@tiscali.co.uk>
> > Date                : 2010-01-31 23:55 (8 days old)
> > References  : http://marc.info/?l=linux-kernel&m=126498212613051&w=4
> 
> Yes, still so in 2.6.33-rc7.
Comment 2 Rafael J. Wysocki 2010-03-22 21:26:27 UTC
On Monday 22 March 2010, Hugh Dickins wrote:
> On Sun, 21 Mar 2010, Rafael J. Wysocki wrote:
> > The following bug entry is on the current list of known regressions
> > introduced between 2.6.32 and 2.6.33.  Please verify if it still should
> > be listed and let the tracking team know (either way).
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=15202
> > Subject             : lockdep warning during elevator_switch
> > Submitter   : Hugh Dickins <hugh.dickins@tiscali.co.uk>
> > Date                : 2010-01-31 23:55 (50 days old)
> > References  : http://marc.info/?l=linux-kernel&m=126498212613051&w=4
> 
> Yes, it is still a regression 2.6.33.1 (though fixed in 2.6.34-rc1:
> my guess is that it will be left as a regression in 2.6.33-stable,
> since it only happens when you have chosen CONFIG_PROVE_LOCKING=y).

Note You need to log in before you can comment on or make changes to this bug.