Bug 15198 - Radeon KMS regression
Summary: Radeon KMS regression
Status: CLOSED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri
URL:
Keywords:
Depends on:
Blocks: 14885
  Show dependency tree
 
Reported: 2010-02-01 00:02 UTC by Rafael J. Wysocki
Modified: 2010-02-02 20:25 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc6
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-02-01 00:02:10 UTC
Subject    : Radeon KMS regression still present in 2.6.33-rc6
Submitter  : Kevin Winchester <kjwinchester@gmail.com>
Date       : 2010-01-30 17:18
References : http://marc.info/?l=linux-kernel&m=126487191019612&w=4
Handled-By : FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Patch      : http://patchwork.kernel.org/patch/75023/

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 42590a75019a50012f25a962246498dead428433
Author: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
Date:   Mon Jan 4 16:16:23 2010 +0900

    x86/agp: Fix agp_amd64_init and agp_amd64_cleanup

    This fixes the regression introduced by the commit
    f405d2c02395a74d3883bd03ded36457aa3697ad.

    Signed-off-by: FUJITA Tomonori <fujita.tomonori@lab.ntt.co.jp>
    LKML-Reference: <20100104161603L.fujita.tomonori@lab.ntt.co.jp>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 42590a75019a50012f25a962246498dead428433
Comment 1 Rafael J. Wysocki 2010-02-01 22:05:22 UTC
Fixed by commit 61684ceaad4f65d1a9832c722f7bd5e7fc714de9.
Comment 2 Rafael J. Wysocki 2010-02-02 20:25:11 UTC
On Tuesday 02 February 2010, Kevin Winchester wrote:
> On Mon, 2010-02-01 at 01:22 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry   : http://bugzilla.kernel.org/show_bug.cgi?id=15198
> > Subject             : Radeon KMS regression
> > Submitter   : Kevin Winchester <kjwinchester@gmail.com>
> > Date                : 2010-01-30 17:18 (2 days old)
> > 
> > 
> 
> This is fixed by the patch from FUJITA Tomonori - I just confirmed with
> my latest build of Linus' tree (which has the patch).

Note You need to log in before you can comment on or make changes to this bug.