Bug 15193 - kswapd continuously active
kswapd continuously active
Status: RESOLVED PATCH_ALREADY_AVAILABLE
Product: IO/Storage
Classification: Unclassified
Component: Block Layer
All Linux
: P1 normal
Assigned To: Jens Axboe
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2010-01-31 22:50 UTC by Rafael J. Wysocki
Modified: 2011-06-13 09:42 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.2
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-31 22:50:57 UTC
Subject    : kswapd continuously active
Submitter  : Jan Engelhardt <jengelh@medozas.de>
Date       : 2010-01-22 23
References : http://marc.info/?l=linux-kernel&m=126420434519039&w=4
Handled-By : Jens Axboe <jens.axboe@oracle.com>

This entry is being used for tracking a regression from 2.6.31.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Jens Axboe 2010-02-12 12:59:57 UTC
Should be fixed by:

http://lkml.org/lkml/2010/2/12/41

which I hope will soon go in (for both .32 and .33).
Comment 2 Rafael J. Wysocki 2010-02-12 23:46:30 UTC
Patch : http://patchwork.kernel.org/patch/78856/
Handled-By : Jens Axboe <jens.axboe@oracle.com>
Comment 3 Marius Tolzmann 2010-06-24 09:32:32 UTC
Hi..

is this patch already applied to the mainline kernel?

we are currently having trouble with continuously running kswapds consuming up to 100% CPU time when the system is busy doing (heavy) I/O.

to reproduce:  dd if=/dev/zero of=somefile  will activate all kswapds when the file reaches the size of the installed memory (our systems have 8G up to 256G). (same effect on local reiserfs and local xfs)

In kernel 2.6.34 (and 2.6.35-rc3) this issue causes the system to become very very slow and unresponsive.

i don't want to file this as a new bug since our issue may be related to this bug?

regards, 
marius tolzmann
Comment 4 Pádraig Brady 2011-06-13 09:42:29 UTC
I'm seeing something very like this on 2.6.38.8-31.fc15.x86_64
on sandy bridge (dual core i3).

I've 3G RAM, 1.5G swap.
100% of the time when a file >= 2G is cached, kswapd0 will spin.
Uncaching the file by rm'ing it etc. will stop it from spinning.
It sometimes happens for files between 1.5G and 2G.

More details at https://bugzilla.redhat.com/show_bug.cgi?id=712019

Note You need to log in before you can comment on or make changes to this bug.