Bug 15192 - netperf ~50% regression with 2.6.33-rc1, bisect to 1b9508f
netperf ~50% regression with 2.6.33-rc1, bisect to 1b9508f
Status: CLOSED CODE_FIX
Product: Process Management
Classification: Unclassified
Component: Scheduler
All Linux
: P1 normal
Assigned To: Ingo Molnar
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-01-31 22:45 UTC by Rafael J. Wysocki
Modified: 2010-03-22 21:29 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-31 22:45:29 UTC
Subject    : netperf ~50% regression with 2.6.33-rc1, bisect to 1b9508f
Submitter  : Lin Ming <ming.m.lin@intel.com>
Date       : 2010-01-25 10:03
References : http://marc.info/?l=linux-kernel&m=126441481427331&w=4
Handled-By : Mike Galbraith <efault@gmx.de>
Handled-By : Peter Zijlstra <peterz@infradead.org>

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-01-31 22:54:23 UTC
Bisection turned up:

commit 1b9508f6831e10d53256825de8904caa22d1ca2c
Author: Mike Galbraith <efault@gmx.de>
Date:   Wed Nov 4 17:53:50 2009 +0100

    sched: Rate-limit newidle

    Rate limit newidle to migration_cost. It's a win for all
    stages of sysbench oltp tests.

    Signed-off-by: Mike Galbraith <efault@gmx.de>
    LKML-Reference: <new-submission>
    Signed-off-by: Ingo Molnar <mingo@elte.hu>

First-Bad-Commit : 1b9508f6831e10d53256825de8904caa22d1ca2c
Comment 2 Rafael J. Wysocki 2010-02-02 20:38:27 UTC
On Monday 01 February 2010, Mike Galbraith wrote:
> On Mon, 2010-02-01 at 01:22 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> 
> Yes, it should remain open.  We're currently waiting for some data from
> Lin Ming.  The regression itself isn't making much sense.. a kernel with
> NEWIDLE disabled should show the same performance, but does not.
Comment 3 Albert Strasheim 2010-02-19 12:46:38 UTC
Sounds a lot like the bug I reported here:

https://bugzilla.redhat.com/show_bug.cgi?id=559943

Intel e1000e NIC in a Sun X6270 blade.
Comment 4 Rafael J. Wysocki 2010-02-21 20:42:17 UTC
Patch : http://patchwork.kernel.org/patch/78544/
Handled-By : Venkatesh Pallipadi <venkatesh.pallipadi@intel.com>
Comment 5 Rafael J. Wysocki 2010-03-22 21:29:37 UTC
Fixed by commit d306ebc28649b89877a22158fe0076f06cc46f60 .

Note You need to log in before you can comment on or make changes to this bug.