Bug 15190 - second suspend fails and system freezes in hp 6910P laptop
second suspend fails and system freezes in hp 6910P laptop
Status: CLOSED CODE_FIX
Product: Power Management
Classification: Unclassified
Component: Hibernation/Suspend
All Linux
: P1 high
Assigned To: power-management_other
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2010-01-31 15:53 UTC by Jithin Emmanuel
Modified: 2011-01-17 00:17 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.32-6
Tree: Mainline
Regression: Yes


Attachments

Description Jithin Emmanuel 2010-01-31 15:53:10 UTC
Hi,
Suspend to ram works for first time. Second time when I try system freezes. I am not seeing any errors on kernel logs. 

I use intel 965GM graphics. And this issue is reproducible all times.
Comment 1 Andrew Morton 2010-02-01 21:15:56 UTC
You say it's a regression.  From which kernel version?  Was 2.6.32 OK?

Thanks.
Comment 2 Jithin Emmanuel 2010-02-02 01:17:17 UTC
Yes 2.6.32 was fine. I installed 2.6.32-7 and yesterday. I also installed acpid.
After that I was able to suspend/resume multiple times. Just when I thought it was working again it froze again. But now it appears to be random.
I dont know if acpid is needed at all, I use kde and power related thing was correctly managed by its power manage power devil.

I am npot getting anything in the logs either. I tried to ssh to my host during it froze, but it seems that it froze after network was deactivated.
Comment 3 Len Brown 2010-02-02 03:00:46 UTC
What is the latest kernel where this never happens, 2.6.32?
What is the earliest kernel where this issues is seen -- 2.6.32.7?

Is it possible to bisect and find the commit that caused the regression?
Comment 4 Jithin Emmanuel 2010-02-02 04:02:53 UTC
The earliest I think is 2.6.32.7. Latest I am not sure its 2.6.32 latest working one. It should be 2.6.31 
I am having a lot of freezes with 2.6.32 kernel. Suspend is one of them it also happens during shutdown/restart. I ignored them for a while, and I guess I am little bit later in reporting the issue. . Then I saw in arch forums lots of others also having same system freeze under different scenario. So I decided to report the issue here.
Comment 5 Rafael J. Wysocki 2010-02-02 20:09:02 UTC
(In reply to comment #4)
> The earliest I think is 2.6.32.7. Latest I am not sure its 2.6.32 latest
> working one. It should be 2.6.31 

Adding to the list of regressions from 2.6.31.

Could you please test 2.6.33-rc6?
Comment 6 Ron Murray 2010-02-02 21:17:51 UTC
I have the same problem (Sony VGN-CR507E laptop, Debian/squeeze, GM965 graphics). I first noticed the problem around 2.6.32.3, but since 2.6.32 also brought problems with resuming with the iwlagn wireless driver, I hadn't tried to suspend/resume twice.

Suspend/resume the first time works fine, suspending the second time fails with a blank screen, underline cursor in the top left corner. Haven't found a key sequence that does anything, and the only recourse is to power down and restart.

last entries in pm-suspend.log:

/usr/lib/pm-utils/sleep.d/00powersave suspend suspend: success.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95anacron suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: success.
/etc/pm/sleep.d/99laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: disabled.
/etc/pm/sleep.d/action_wpa suspend suspend: success.
Wed Jan 20 22:00:23 EST 2010: performing suspend


 .
Comment 7 Jithin Emmanuel 2010-02-03 01:57:15 UTC
I dont know if these are related my system froze during VT switch. Like the nature of this bug I was able to do VT switch multiple times without any issues and it just froze. Dont know how many time I successfully did the switch.
And there was nothing in the logs. 
I will upgrade to 2.6.33-rc6 now and check.
Comment 8 Jithin Emmanuel 2010-02-03 09:40:06 UTC
I installed 2.6.33-rc6. So far things are good. Did 5 suspend/resume in a row and is working. Also I removed acpid.
Lately there so many random freezes I am facing. So I will monitor for a couple for days and report back.
Comment 9 Jithin Emmanuel 2010-02-03 17:48:29 UTC
I got a freeze when rebooting. I downgraded to 2.6.31.5 kernel and everything seems to be working fine.
Comment 10 Ron Murray 2010-03-02 02:36:39 UTC
Problem still in evidence with kernel version 2.6.33.
Comment 11 Ron Murray 2010-03-19 01:32:52 UTC
Today I grabbed the testing 2.6.32 kernels and compiled them all. Tried 2.6.32-rc1 first and had it fail on the second suspend/resume cycle, just like the production 2.6.32 kernels. Looks like the problem is somewhere in the 5.8M of changelog associated with 2.6.32-rc1.

I suspect that the problem is in the graphics system, because that's where it seems to be hanging. The effect I get has changed somewhat: originally I had a blank screen with an underline cursor, but now I get half an X screen (looks like it died halfway though the screensaver painting the screen). Some things have changed in userspace on the laptop, including a new grub that makes more use of weird framebuffer devices.

Any ideas on where to look next?
Comment 12 Rafael J. Wysocki 2011-01-16 22:56:06 UTC
Is the problem still present in 2.6.37?
Comment 13 Ron Murray 2011-01-16 23:45:20 UTC
It was fixed somewhere around 2.6.34, I think. Sorry, I thought I'd sent an update, but apparently not.

Note You need to log in before you can comment on or make changes to this bug.