Bug 15188 - Graphic subsystem freeze
Graphic subsystem freeze
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 high
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14230
  Show dependency treegraph
 
Reported: 2010-01-31 12:13 UTC by aix27249
Modified: 2010-02-21 21:33 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32.6
Tree: Mainline
Regression: Yes


Attachments
Kernel config (102.57 KB, application/octet-stream)
2010-01-31 12:13 UTC, aix27249
Details

Description aix27249 2010-01-31 12:13:35 UTC
Created attachment 24820 [details]
Kernel config

X11 completely freezes sometimes, usually (but not always) after long uptime (about 10 hours).

Switching to first console and back still works, but X11 remains unusable even after restarting X server.

When it happens, I see huge amount of messages like this in dmesg:

[56922.328238] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[56922.425534] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[56922.525589] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[56922.625558] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[56922.706773] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged

Hardware:
Apple Macbook 1st gen

lspci:
root@mac:~# lspci
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)
00:07.0 Performance counters: Intel Corporation Device 27a3 (rev 03)
00:1b.0 Audio device: Intel Corporation 82801G (ICH7 Family) High Definition Audio Controller (rev 02)
00:1c.0 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 1 (rev 02)
00:1c.1 PCI bridge: Intel Corporation 82801G (ICH7 Family) PCI Express Port 2 (rev 02)
00:1d.0 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #1 (rev 02)
00:1d.1 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #2 (rev 02)
00:1d.2 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #3 (rev 02)
00:1d.3 USB Controller: Intel Corporation 82801G (ICH7 Family) USB UHCI Controller #4 (rev 02)
00:1d.7 USB Controller: Intel Corporation 82801G (ICH7 Family) USB2 EHCI Controller (rev 02)
00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev e2)
00:1f.0 ISA bridge: Intel Corporation 82801GBM (ICH7-M) LPC Interface Bridge (rev 02)
00:1f.1 IDE interface: Intel Corporation 82801G (ICH7 Family) IDE Controller (rev 02)
00:1f.2 IDE interface: Intel Corporation 82801GBM/GHM (ICH7 Family) SATA IDE Controller (rev 02)
00:1f.3 SMBus: Intel Corporation 82801G (ICH7 Family) SMBus Controller (rev 02)
01:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8053 PCI-E Gigabit Ethernet Controller (rev 22)
02:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG [Golan] Network Connection (rev 02)
03:03.0 FireWire (IEEE 1394): Agere Systems FW322/323 (rev 61)

Kernel config attached.
Comment 1 aix27249 2010-01-31 12:15:35 UTC
Xorg environment: xorg-server 1.7.4, xf86-video-intel 2.10.0 (using KMS), mesa 7.7, gcc 4.4.2. As desktop environment - KDE 4.3.4 with compositing enabled.
Comment 2 aix27249 2010-02-02 01:32:24 UTC
Additional info: seems that bug appears only after few suspends.
Comment 3 aix27249 2010-02-08 03:35:06 UTC
Bug still exist in 2.6.32.7
Comment 4 aix27249 2010-02-10 03:43:32 UTC
Update: reproduced bug without any suspend (just after 1 hour uptime), so it is not related to suspend/resume problems.
Comment 5 aix27249 2010-02-15 16:22:50 UTC
Seems that this bug wasn't related directly to the kernel, because recent libdrm fixes solved the problem.

So, I think this bug is solved, and can be closed.

Note You need to log in before you can comment on or make changes to this bug.