Bug 15171 - smartd crashing recent 2.6.32 kernel
smartd crashing recent 2.6.32 kernel
Status: RESOLVED OBSOLETE
Product: SCSI Drivers
Classification: Unclassified
Component: Other
All Linux
: P1 high
Assigned To: scsi_drivers-other
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 20:55 UTC by Roland Kletzing
Modified: 2012-11-20 16:45 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments

Description Roland Kletzing 2010-01-29 20:55:35 UTC
This bugticket is used to track an issue already opened in novell-bugzilla (https://bugzilla.novell.com/show_bug.cgi?id=573244) and reported on linux-scsi and smartmontools-support (http://marc.info/?l=smartmontools-support&m=126462075603274&w=2)

as it appears to be an upstream issue, i`m additionally adding it here. i only have that box for another week or two so it`s a small timeslot to test fixes on that box.

short description:
linux kernel crashes (system freeze) at late installation stage when smartd being started. seems smartd sends an ioctl which the driver (megaraid_mbox) doesn`t like.
Comment 1 Roland Kletzing 2010-02-22 19:49:41 UTC
...and reported on lkml, being cc`d to several more by Robert Hancock, see http://marc.info/?l=linux-kernel&m=126662861309996&w=2
Comment 2 Roland Kletzing 2010-02-22 19:50:55 UTC
and we have a possibel dupe

*** This bug has been marked as a duplicate of bug 12544 ***
Comment 3 Roland Kletzing 2010-02-22 19:52:14 UTC
and we have a possibel dupe
Comment 4 Roland Kletzing 2010-02-22 19:53:21 UTC
doh, accidentally switched to resolved. no, this is not resolved
Comment 5 Roland Kletzing 2010-02-23 18:51:01 UTC
or reference: http://marc.info/?l=linux-kernel&m=126686985804305&w=2

Note You need to log in before you can comment on or make changes to this bug.