Bug 15170 - Wireless card problem on Acer Extes
Wireless card problem on Acer Extes
Status: CLOSED CODE_FIX
Product: Networking
Classification: Unclassified
Component: Wireless
All Linux
: P1 normal
Assigned To: networking_wireless@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-29 13:15 UTC by Fabrizio
Modified: 2010-08-13 23:48 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.31.8-0.1-default
Tree: Mainline
Regression: No


Attachments

Description Fabrizio 2010-01-29 13:15:51 UTC
I have a wireless card AR928X Wireless Network Adapter, and use openSuse 11.2.
When I use the wireless card too much (downloading a lot of things), I hear a system beep and suddenly connection breaks up and it doesn't connect until reboot.



This is what I get (localmessages):

Jan 29 11:29:21 linux-g3rs checkproc: checkproc: can not get session id for process 2361!
Jan 29 12:08:00 linux-g3rs checkproc: checkproc: can not get session id for process 2366!
Jan 29 12:10:36 linux-g3rs checkproc: checkproc: can not get session id for process 2135!



This is what I get on the screen:

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.159359] Oops: 0000 [#1] SMP 

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.159369] last sysfs file: /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/devnum

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.159713] Process phy0 (pid: 534, ti=f515a000 task=f66f6270 task.ti=f515a000)

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.159723] Stack:

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.159788] Call Trace:

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.160006] Code: 26 00 00 00 00 e8 ab d6 f6 ff 8d 74 26 00 8d bc 27 00 00 00 00 55 89 e5 83 ec 18 89 5d f4 89 c3 65 a1 14 00 00 00 89 45 f0 31 c0 <f7> 03 00 00 03 00 89 75 f8 89 7d fc 0f 85 e5 00 00 00 f0 ff 4b 

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.160006] EIP: [<c02e1da6>] put_page+0x16/0x120 SS:ESP 0068:f515bd84

Message from syslogd@linux-g3rs at Jan 29 14:04:45 ...
 kernel:[ 3696.160006] CR2: 0000000000000001



Dmesg:

[ 2889.367218] wlan0: associated
[ 3251.001043] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3252.186610] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3252.385045] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3252.387045] wlan0: authenticated
[ 3252.387052] wlan0: associate with AP 00:11:20:68:be:50
[ 3252.389632] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=233)
[ 3252.389638] wlan0: associated
[ 3376.004150] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3377.186182] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3377.384079] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3377.385773] wlan0: authenticated
[ 3377.385779] wlan0: associate with AP 00:11:20:68:be:50
[ 3377.387990] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=238)
[ 3377.387995] wlan0: associated
[ 3456.004128] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3457.191312] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3457.194751] wlan0: authenticated
[ 3457.194758] wlan0: associate with AP 00:11:20:68:be:50
[ 3457.204770] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=240)
[ 3457.204779] wlan0: associated
[ 3471.005048] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3472.186710] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3472.188629] wlan0: authenticated
[ 3472.188637] wlan0: associate with AP 00:11:20:68:be:50
[ 3472.192221] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=241)
[ 3472.192228] wlan0: associated
[ 3575.988065] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3577.175363] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3577.177540] wlan0: authenticated
[ 3577.177548] wlan0: associate with AP 00:11:20:68:be:50
[ 3577.181047] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=245)
[ 3577.181053] wlan0: associated
[ 3591.000143] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3592.187205] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3592.189059] wlan0: authenticated
[ 3592.189066] wlan0: associate with AP 00:11:20:68:be:50
[ 3592.191952] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=246)
[ 3592.191958] wlan0: associated
[ 3616.000106] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3617.192726] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3617.195899] wlan0: authenticated
[ 3617.195904] wlan0: associate with AP 00:11:20:68:be:50
[ 3617.206236] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=247)
[ 3617.206242] wlan0: associated
[ 3656.004199] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3657.186858] wlan0: authenticate with AP 00:11:20:68:be:50
[ 3657.188580] wlan0: authenticated
[ 3657.188588] wlan0: associate with AP 00:11:20:68:be:50
[ 3657.190808] wlan0: RX ReassocResp from 00:11:20:68:be:50 (capab=0x421 status=0 aid=249)
[ 3657.190814] wlan0: associated
[ 3686.005103] wlan0: no probe response from AP 00:11:20:68:be:50 - disassociating
[ 3687.206388] wlan0: authenticate with AP 00:17:0f:23:96:d0
[ 3687.208078] wlan0: authenticated
[ 3687.208084] wlan0: associate with AP 00:17:0f:23:96:d0
[ 3687.210133] wlan0: RX ReassocResp from 00:17:0f:23:96:d0 (capab=0x421 status=0 aid=60)
[ 3687.210140] wlan0: associated
[ 3696.004058] wlan0: no probe response from AP 00:17:0f:23:96:d0 - disassociating
[ 3696.159312] BUG: unable to handle kernel NULL pointer dereference at 00000001
[ 3696.159333] IP: [<c02e1da6>] put_page+0x16/0x120
[ 3696.159350] *pde = 00000000 
[ 3696.159359] Oops: 0000 [#1] SMP 
[ 3696.159369] last sysfs file: /sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/devnum
[ 3696.159381] Modules linked in: lp parport_pc ppdev parport st ide_gd_mod ide_cd_mod ide_core nfs lockd fscache nfs_acl auth_rpcgss sunrpc af_packet ip6t_LOG xt_tcpudp xt_pkttype ipt_LOG xt_limit snd_pcm_oss snd_mixer_oss snd_seq snd_seq_device edd i915 drm i2c_algo_bit binfmt_misc ip6t_REJECT nf_conntrack_ipv6 ip6table_raw xt_NOTRACK ipt_REJECT xt_state iptable_raw iptable_filter ip6table_mangle nf_conntrack_netbios_ns nf_conntrack_ipv4 nf_conntrack nf_defrag_ipv4 ip_tables ip6table_filter ip6_tables x_tables ipv6 fuse loop dm_mod arc4 ecb cryptomgr aead pcompress crypto_blkcipher crypto_hash crypto_algapi sr_mod sg snd_hda_codec_conexant video output iTCO_wdt i2c_i801 uvcvideo videodev v4l1_compat ath9k mac80211 ath cdrom joydev serio_raw acer_wmi cfg80211 i2c_core led_class pcspkr atl1c iTCO_vendor_support rfkill snd_hda_intel battery wmi snd_hda_codec snd_hwdep ac button snd_pcm snd_timer snd soundcore snd_page_alloc intel_agp ext4 jbd2 crc16 usbhid hid ata_generic ata_piix rtc_cmos rtc_core rtc_lib ahci uhci_hcd libata ehci_hcd fan thermal processor thermal_sys hwmon [last unloaded: parport_pc]
[ 3696.159645] 
[ 3696.159653] Pid: 534, comm: phy0 Not tainted (2.6.31.8-0.1-default #1) Extensa 5635Z    
[ 3696.159665] EIP: 0060:[<c02e1da6>] EFLAGS: 00010246 CPU: 0
[ 3696.159675] EIP is at put_page+0x16/0x120
[ 3696.159683] EAX: 00000000 EBX: 00000001 ECX: f5ff2d80 EDX: f6577d40
[ 3696.159693] ESI: f5ff2d80 EDI: f5ff2d80 EBP: f515bd9c ESP: f515bd84
[ 3696.159703]  DS: 007b ES: 007b FS: 00d8 GS: 00e0 SS: 0068
[ 3696.159713] Process phy0 (pid: 534, ti=f515a000 task=f66f6270 task.ti=f515a000)
[ 3696.159723] Stack:
[ 3696.159728]  00000000 00000000 7e089908 00000001 00000000 7e089908 f515bdb0 c055f0a7
[ 3696.159745] <0> 7e089908 f5ff2d80 00000009 f515bdc0 c055eac2 7e089908 f67761a0 f515bdcc
[ 3696.159765] <0> c055eb8b 7e089908 f515be0c f8947607 7e089908 f515bde8 c06031c4 7e089908
[ 3696.159788] Call Trace:
[ 3696.159808]  [<c055f0a7>] skb_release_data+0xa7/0xc0
[ 3696.159823]  [<c055eac2>] __kfree_skb+0x22/0xc0
[ 3696.159836]  [<c055eb8b>] consume_skb+0x2b/0x60
[ 3696.159871]  [<f8947607>] ieee80211_tx_status+0x457/0x490 [mac80211]
[ 3696.159911]  [<f8adc2f2>] ath_tx_complete+0xe2/0x110 [ath9k]
[ 3696.159964]  [<f8adc39c>] ath_tx_complete_buf+0x7c/0xe0 [ath9k]
[ 3696.160006]  [<f8add89c>] ath_draintxq+0x14c/0x2a0 [ath9k]
[ 3696.160006]  [<f8adf1a6>] ath_drain_all_txq+0xf6/0x130 [ath9k]
[ 3696.160006]  [<f8ada75e>] ath_set_channel+0x8e/0x180 [ath9k]
[ 3696.160006]  [<f8adaa02>] ath9k_config+0x1b2/0x210 [ath9k]
[ 3696.160006]  [<f8946166>] ieee80211_hw_config+0x86/0xe0 [mac80211]
[ 3696.160006]  [<f894bba2>] ieee80211_scan_work+0xc2/0x230 [mac80211]
[ 3696.160006]  [<c02664ee>] run_workqueue+0x9e/0x1b0
[ 3696.160006]  [<c0266690>] worker_thread+0x90/0x100
[ 3696.160006]  [<c026bcd4>] kthread+0x84/0x90
[ 3696.160006]  [<c0204db7>] kernel_thread_helper+0x7/0x10
[ 3696.160006] Code: 26 00 00 00 00 e8 ab d6 f6 ff 8d 74 26 00 8d bc 27 00 00 00 00 55 89 e5 83 ec 18 89 5d f4 89 c3 65 a1 14 00 00 00 89 45 f0 31 c0 <f7> 03 00 00 03 00 89 75 f8 89 7d fc 0f 85 e5 00 00 00 f0 ff 4b 
[ 3696.160006] EIP: [<c02e1da6>] put_page+0x16/0x120 SS:ESP 0068:f515bd84
[ 3696.160006] CR2: 0000000000000001
[ 3696.160481] ---[ end trace 63b341a7dd6a0e38 ]---
Comment 1 John W. Linville 2010-05-12 18:16:46 UTC
What kernel version are you using?  Does the problem exist on current linux-2.6 kernels?
Comment 2 Fabrizio 2010-05-14 08:46:16 UTC
Yes, it exists; I'm using the last updated versions of openSUSE and Debian, and I'm getting the same error. It is an error related to kNetworkManager, now I'm using iwconfig and dhclient (Debian) and I'm not getting errors anymore.
Comment 3 John W. Linville 2010-08-13 16:14:44 UTC
I'm sorry to seem dense, but did you actually try an upstream kernel?  Or only "last updated versions of openSUSE and Debian"?  Those are not at all the same things.

Please replicate the problem with a 2.6.35 (or later) kernel and post the current backtrace here...thanks!
Comment 4 John W. Linville 2010-08-13 23:48:18 UTC
Private email:

From: Fabrizio Berloco <fabri_berloco@yahoo.it>
Subject: Re
To: linville@tuxdriver.com

I can't reply online, because i don't have access anymore to
bugzilla.kernel.org.
The problem doesn't affect today kernels in Debian, OpenSUSE and Fedora. Now my
card is working

very very good.

See ya

Note You need to log in before you can comment on or make changes to this bug.