Bug 15146 - freeze on ppp connection (using an usb "key" modem)
freeze on ppp connection (using an usb "key" modem)
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: USB
All Linux
: P1 normal
Assigned To: Greg Kroah-Hartman
:
Depends on:
Blocks: 13615
  Show dependency treegraph
 
Reported: 2010-01-26 14:02 UTC by Fabio Bas
Modified: 2010-03-22 19:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.5 x86_64 SMP
Tree: Mainline
Regression: Yes


Attachments
/proc/cpuinfo output (1.78 KB, text/plain)
2010-01-26 14:05 UTC, Fabio Bas
Details
kernel log (4.96 KB, text/plain)
2010-01-26 14:05 UTC, Fabio Bas
Details
lspci -vvv output (35.54 KB, text/plain)
2010-01-26 14:05 UTC, Fabio Bas
Details
lsusb -v output on the device (13.77 KB, text/plain)
2010-01-26 14:06 UTC, Fabio Bas
Details
/proc/ioports output (3.97 KB, text/plain)
2010-01-26 14:07 UTC, Fabio Bas
Details
/proc/modules output (4.73 KB, text/plain)
2010-01-26 14:07 UTC, Fabio Bas
Details
/proc/scsi/scsi output (529 bytes, text/plain)
2010-01-26 14:07 UTC, Fabio Bas
Details
ver_linux script output (1.75 KB, text/plain)
2010-01-26 14:08 UTC, Fabio Bas
Details
kernel log with sysrq-t (13.40 KB, text/plain)
2010-01-26 14:09 UTC, Fabio Bas
Details
proc_tty_devices output (708 bytes, text/plain)
2010-01-26 14:13 UTC, Fabio Bas
Details

Description Fabio Bas 2010-01-26 14:02:29 UTC
I'm using a "Vodafone Mobile Connect" (the real producer is "Option" and
the model is "K3760 HSPA USB STICK", FCC ID: NCMOGI0411) usb modem to
create a ppp connection to the Internet.
I connect the usb stick, call "usb_modeswitch" (this is needed to flip
the device from "memory storage" mode to "modem" mode), and then run
"pppd call vodafone".
The connection will tipically work for 10secs to 1 minute, then the
system will look up hard:
- video show a still image
- keyboard leds doesn't switch their state (caps lock, num lock, ...
doesn't work)
- the cpu fan start rotating at full speed.
- No disk/network/other activity at all
I need to "pull the plug" to force a shutdown.

The last working kernel i'm aware of is kernel 2.6.30, the first showing
the problem 2.6.32.2

This problem was first reported here: http://lkml.org/lkml/2010/1/26/121
Comment 1 Fabio Bas 2010-01-26 14:05:22 UTC
Created attachment 24720 [details]
/proc/cpuinfo output
Comment 2 Fabio Bas 2010-01-26 14:05:40 UTC
Created attachment 24721 [details]
kernel log
Comment 3 Fabio Bas 2010-01-26 14:05:59 UTC
Created attachment 24722 [details]
lspci -vvv output
Comment 4 Fabio Bas 2010-01-26 14:06:21 UTC
Created attachment 24723 [details]
lsusb -v output on the device
Comment 5 Fabio Bas 2010-01-26 14:07:02 UTC
Created attachment 24724 [details]
/proc/ioports output
Comment 6 Fabio Bas 2010-01-26 14:07:22 UTC
Created attachment 24725 [details]
/proc/modules output
Comment 7 Fabio Bas 2010-01-26 14:07:40 UTC
Created attachment 24726 [details]
/proc/scsi/scsi output
Comment 8 Fabio Bas 2010-01-26 14:08:01 UTC
Created attachment 24727 [details]
ver_linux script output
Comment 9 Fabio Bas 2010-01-26 14:09:56 UTC
Created attachment 24728 [details]
kernel log with sysrq-t
Comment 10 Fabio Bas 2010-01-26 14:13:03 UTC
Created attachment 24729 [details]
proc_tty_devices output

I was asked if i was using the serial or the cdc-acm driver
Comment 11 Andrew Morton 2010-01-28 00:46:38 UTC
(switched to email.  Please respond via emailed reply-to-all, not via the
bugzilla web interface).

On Tue, 26 Jan 2010 14:02:31 GMT
bugzilla-daemon@bugzilla.kernel.org wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=15146
> 
>            Summary: freeze on ppp connection (using an usb "key" modem)
>            Product: Other
>            Version: 2.5
>     Kernel Version: 2.6.32.5 x86_64 SMP
>           Platform: All
>         OS/Version: Linux
>               Tree: Mainline
>             Status: NEW
>           Severity: normal
>           Priority: P1
>          Component: Other
>         AssignedTo: other_other@kernel-bugs.osdl.org
>         ReportedBy: fabio.bas@officineinformatiche.net
>         Regression: No
> 
> 
> I'm using a "Vodafone Mobile Connect" (the real producer is "Option" and
> the model is "K3760 HSPA USB STICK", FCC ID: NCMOGI0411) usb modem to
> create a ppp connection to the Internet.
> I connect the usb stick, call "usb_modeswitch" (this is needed to flip
> the device from "memory storage" mode to "modem" mode), and then run
> "pppd call vodafone".
> The connection will tipically work for 10secs to 1 minute, then the
> system will look up hard:
> - video show a still image
> - keyboard leds doesn't switch their state (caps lock, num lock, ...
> doesn't work)
> - the cpu fan start rotating at full speed.
> - No disk/network/other activity at all
> I need to "pull the plug" to force a shutdown.
> 
> The last working kernel i'm aware of is kernel 2.6.30, the first showing
> the problem 2.6.32.2
> 
> This problem was first reported here: http://lkml.org/lkml/2010/1/26/121
> 

post-2.6.30 regression, seems to be in the usb-serial area.
Comment 12 Greg Kroah-Hartman 2010-01-28 01:06:55 UTC
On Wed, Jan 27, 2010 at 04:46:33PM -0800, Andrew Morton wrote:
> > The last working kernel i'm aware of is kernel 2.6.30, the first showing
> > the problem 2.6.32.2

So 2.6.32.1 works properly?

Can you try 2.6.32.6?  I think this should now be resolved.

thanks,

greg k-h
Comment 13 Fabio Bas 2010-03-22 17:07:30 UTC
The issue is still present in both 2.6.32.7 and 2.6.33. In the meanwhile, i've tried several different usb key modems (of a different brand, huawei) and they all works just fine.
So, i suspect that the issue could be caused by a semi-failed hardware: it's probably just a matter of this usb key bitching on the usb port. Therefore, i'm closing this ticket myself as invalid

Note You need to log in before you can comment on or make changes to this bug.