Bug 15144 - HDA Intel Audio hang on boot
HDA Intel Audio hang on boot
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Takashi Iwai
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-01-25 21:10 UTC by Rafael J. Wysocki
Modified: 2010-02-14 21:49 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-25 21:10:51 UTC
Subject    : HDA Intel Audio hang on boot
Submitter  : Sid Boyce <sboyce@blueyonder.co.uk>
Date       : 2010-01-15 1:24
References : http://marc.info/?l=linux-kernel&m=126351866722507&w=4
Notify-Also : Takashi Iwai <tiwai@suse.de>

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-01-25 21:11:55 UTC
On Monday 25 January 2010, Sid Boyce wrote:
> On 15/01/10 01:24, Sid Boyce wrote:
> This is the only outstanding bug. No problems up 2.6.32-git1, but I get
> a solid lock-up on 2.6.32-git2 through 2.6.33-rc5 if the on-board audio
> is not disabled in the BIOS.
Comment 3 Rafael J. Wysocki 2010-02-14 21:49:23 UTC
On Sunday 14 February 2010, Sid Boyce wrote:
> On 01/02/10 06:43, Takashi Iwai wrote:
> > At Mon, 01 Feb 2010 02:01:21 +0000,
> > Sid Boyce wrote:
> >>
> >> On 01/02/10 00:22, Rafael J. Wysocki wrote:
> >>> This message has been generated automatically as a part of a report
> >>> of recent regressions.
> >>>
> >>> The following bug entry is on the current list of known regressions
> >>> from 2.6.32.  Please verify if it still should be listed and let me know
> >>> (either way).
> >>>
> >>>
> >>> Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15144
> >>> Subject		: HDA Intel Audio hang on boot
> >>> Submitter	: Sid Boyce <sboyce@blueyonder.co.uk>
> >>> Date		: 2010-01-15 1:24 (17 days old)
> >>> References	: http://marc.info/?l=linux-kernel&m=126351866722507&w=4
> 
> Up to 2.6.33-rc8 still needs the work around in
> /etc/modprobe.d/50-sound.conf, so the kernel blacklist fix does not work.
> 
> # less /etc/modprobe.d/50-sound.conf
> 
> options slots=snd-hda-intel
> # 9LTX.vLXC8EvZgR7:MCP55 High Definition Audio
> alias snd-card-0 snd-hda-intel
> options snd-hda-intel enable_msi=0

Note You need to log in before you can comment on or make changes to this bug.