Bug 15139 - e1000: transmit queue 0 timed out
Summary: e1000: transmit queue 0 timed out
Status: CLOSED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Network (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jesse Brandeburg
URL:
Keywords:
Depends on:
Blocks: 14885
  Show dependency tree
 
Reported: 2010-01-24 21:19 UTC by Rafael J. Wysocki
Modified: 2010-03-29 20:58 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.33-rc5
Tree: Mainline
Regression: Yes


Attachments
Patch to dump info on tx hang (7.40 KB, patch)
2010-02-24 23:51 UTC, nicholasx.d.nunley
Details | Diff

Description Rafael J. Wysocki 2010-01-24 21:19:34 UTC
Subject    : 2.6.33-rc5: (e1000): transmit queue 0 timed out
Submitter  : Alexander Beregalov <a.beregalov@gmail.com>
Date       : 2010-01-23 15:37
References : http://marc.info/?l=linux-netdev&m=126426149306083&w=4

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.
Comment 1 nicholasx.d.nunley 2010-02-24 23:51:42 UTC
Created attachment 25201 [details]
Patch to dump info on tx hang

Attached is a patch that will dump register and descriptor ring contents when a tx hang is detected. Please apply the patch and provide the output the next time the bug is encountered.

Thanks
Comment 2 Jesse Brandeburg 2010-03-01 20:23:46 UTC
Alexander, can you please try to reproduce with the attached patch in this bug?
Comment 3 Alexander Beregalov 2010-03-25 02:27:59 UTC
I can't reproduce it. Close?
Comment 4 Jesse Brandeburg 2010-03-29 20:22:42 UTC
Well it seems like we cannot and you cannot reproduce.

If the issue comes back up please file a new bug, but for now, let's just close.  Thanks for investigating!

Note You need to log in before you can comment on or make changes to this bug.