Bug 15138 - evdev regression on macbook
evdev regression on macbook
Status: CLOSED INVALID
Product: Drivers
Classification: Unclassified
Component: Input Devices
All Linux
: P1 normal
Assigned To: drivers_input-devices
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-01-24 21:02 UTC by Rafael J. Wysocki
Modified: 2010-02-01 15:10 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc5
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-24 21:02:28 UTC
Subject    : evdev regression on macbook with 2.6.33-rc5
Submitter  : Guillaume Chazarain <guichaz@gmail.com>
Date       : 2010-01-23 18:53
References : http://marc.info/?l=linux-kernel&m=126427286219235&w=4
Handled-By : Dmitry Torokhov <dmitry.torokhov@gmail.com>

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-01-24 21:02:49 UTC
The regression is from 2.6.32.
Comment 2 Dmitry Torokhov 2010-02-01 06:28:14 UTC
This is an issue with a userspace driver (which mouseemu package is) violating input protocol by suppressing all non-key events (which includes EV_SYN). I could think about trying to work around regular userspace application but requrements for drivers are higher and thus I am closing the issue as invalid.

I was intending to create a patch to moueemu package instead but after looking at the source I just want the thing to dies as quickly as possible.

Note You need to log in before you can comment on or make changes to this bug.