Bug 15133 - Wake on LAN doesn't work in sky2
Wake on LAN doesn't work in sky2
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Network
All Linux
: P1 normal
Assigned To: drivers_network@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-01-24 20:32 UTC by Rafael J. Wysocki
Modified: 2010-01-26 11:57 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc4
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-24 20:32:11 UTC
Subject    : Regression: Wake on LAN doesn't work in sky2 with 2.6.33-rc4-git2
Submitter  : Tino Keitel <tino.keitel@tikei.de>
Date       : 2010-01-15 9:10
References : http://marc.info/?l=linux-kernel&m=126354704815848&w=4
Handled-By : Stephen Hemminger <shemminger@vyatta.com>

This entry is being used for tracking a regression from 2.6..  Please don't
close it until the problem is fixed in the mainline.

Caused by:

commit 166a0fd4c788ec7f10ca8194ec6d526afa12db75
Author: stephen hemminger <shemminger@vyatta.com>
Date:   Mon Dec 14 08:50:12 2009 +0000

    sky2: leave PCI config space writeable
    
    Since power management is done by PCI subsystem as well as driver,
    don't toggle the bit that disables PCI register writes.
    
    Signed-off-by: Stephen Hemminger <shemminger@vyatta.com>
    Acked-by: Rafael J. Wysocki <rjw@sisk.pl>
    Signed-off-by: David S. Miller <davem@davemloft.net>

First-Bad-Commit : 166a0fd4c788ec7f10ca8194ec6d526afa12db75

Note You need to log in before you can comment on or make changes to this bug.