Bug 15120 - laptop hangs up on s2disk - Lenovo thinkpad T61
laptop hangs up on s2disk - Lenovo thinkpad T61
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - non Intel)
x86-64 Linux
: P1 normal
Assigned To: drivers_video-dri
:
Depends on:
Blocks: 7216 56331
  Show dependency treegraph
 
Reported: 2010-01-24 12:44 UTC by Alex Zhavnerchik
Modified: 2013-04-09 06:23 UTC (History)
4 users (show)

See Also:
Kernel Version: 2.6.33-rc6
Tree: Mainline
Regression: No


Attachments
kernel config (90.23 KB, application/octet-stream)
2010-01-27 10:05 UTC, Alex Zhavnerchik
Details
kernel log (196.86 KB, application/octet-stream)
2010-02-01 08:51 UTC, Alex Zhavnerchik
Details
dmegs after fail on s2disk and s2ram (122.44 KB, text/plain)
2010-02-02 13:42 UTC, Alex Zhavnerchik
Details
kernel log (276.06 KB, text/plain)
2010-02-03 22:56 UTC, Alex Zhavnerchik
Details

Description Alex Zhavnerchik 2010-01-24 12:44:55 UTC
Hi. I use Lenovo thinkpad T61 with nouveau drm, sometimes it suspends to disk without any problems and resume is always OK. But sometimes (most times actually) it hangs up and I just see "Snapshoting system" message, it blink several times with HDD LED and "moon" LED (everybody who used T61 can understand me :)) is blinking all the time, till I shutdown the PC. 

Kernel config in attach. If I can make this bug report more useful/helpful please instruct me.
Comment 1 Zhang Rui 2010-01-27 07:57:44 UTC
First of all, the kernel config is not attached. :)

what's the kernel version that doesn't work for you?
does the problem still exist in the latest kernel, say 2.6.32?

If yes,please build a .32 kernel with CONFIG_PM_DEBUG.
run "echo test > /sys/power/disk" and "echo disk > /sys/power/state".
does the system come back after a few seconds?
If yes, please attach the dmesg output after resume.
Comment 2 Alex Zhavnerchik 2010-01-27 10:05:38 UTC
Created attachment 24745 [details]
kernel config
Comment 3 Alex Zhavnerchik 2010-01-27 10:10:00 UTC
I'm using 2.6.33-rc5 now with nouveau driver. But may be that is related to one other bug http://bugzilla.kernel.org/show_bug.cgi?id=15119 - a warning described there appears before I do s2disk.
Comment 4 Rafael J. Wysocki 2010-01-27 23:16:13 UTC
Does it also happen without the nouveau driver, eg. at runlevel 3?
Comment 5 Alex Zhavnerchik 2010-01-27 23:41:33 UTC
Sorry can't test now, something broke and now my 2.6.33-rc5 kernel boot but there is no image on screen, I'll answer in this ticket when I'll solve that issue.
Comment 6 Alex Zhavnerchik 2010-01-30 22:53:00 UTC
System didn't returned after that test. I can provide a kernel log. Do you
need the log?

On Wed, Jan 27, 2010 at 9:57 AM, <bugzilla-daemon@bugzilla.kernel.org>wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=15120
>
>
> Zhang Rui <rui.zhang@intel.com> changed:
>
>           What    |Removed                     |Added
>
> ----------------------------------------------------------------------------
>             Status|NEW                         |NEEDINFO
>                 CC|                            |rui.zhang@intel.com
>
>
>
>
> --- Comment #1 from Zhang Rui <rui.zhang@intel.com>  2010-01-27 07:57:44
> ---
> First of all, the kernel config is not attached. :)
>
> what's the kernel version that doesn't work for you?
> does the problem still exist in the latest kernel, say 2.6.32?
>
> If yes,please build a .32 kernel with CONFIG_PM_DEBUG.
> run "echo test > /sys/power/disk" and "echo disk > /sys/power/state".
> does the system come back after a few seconds?
> If yes, please attach the dmesg output after resume.
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 7 Alex Zhavnerchik 2010-01-30 22:58:15 UTC
I can provide dmesg after successful s2disk :)

On Sun, Jan 31, 2010 at 12:53 AM, <bugzilla-daemon@bugzilla.kernel.org>wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=15120
>
>
>
>
>
> --- Comment #6 from Alex Zhavnerchik <alex.vizor@gmail.com>  2010-01-30
> 22:53:00 ---
> System didn't returned after that test. I can provide a kernel log. Do you
> need the log?
>
> On Wed, Jan 27, 2010 at 9:57 AM, <bugzilla-daemon@bugzilla.kernel.org
> >wrote:
>
> > http://bugzilla.kernel.org/show_bug.cgi?id=15120
> >
> >
> > Zhang Rui <rui.zhang@intel.com> changed:
> >
> >           What    |Removed                     |Added
> >
> >
> ----------------------------------------------------------------------------
> >             Status|NEW                         |NEEDINFO
> >                 CC|                            |rui.zhang@intel.com
> >
> >
> >
> >
> > --- Comment #1 from Zhang Rui <rui.zhang@intel.com>  2010-01-27 07:57:44
> > ---
> > First of all, the kernel config is not attached. :)
> >
> > what's the kernel version that doesn't work for you?
> > does the problem still exist in the latest kernel, say 2.6.32?
> >
> > If yes,please build a .32 kernel with CONFIG_PM_DEBUG.
> > run "echo test > /sys/power/disk" and "echo disk > /sys/power/state".
> > does the system come back after a few seconds?
> > If yes, please attach the dmesg output after resume.
> >
> > --
> > Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> > ------- You are receiving this mail because: -------
> > You reported the bug.
> >
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 8 Alex Zhavnerchik 2010-02-01 08:51:53 UTC
Created attachment 24850 [details]
kernel log
Comment 9 Alex Zhavnerchik 2010-02-01 08:58:05 UTC
I caught it again, strange thing happened when the system tried to do s2disk, wifi LED turned off for a second or two and then turned on again. And in log I see messages related with wlan0 and usb bluetooth only. May be that is the reason of such hangs up?
Comment 10 Len Brown 2010-02-02 03:11:32 UTC
please follow the steps in the source tree under 
Documentation/power/basic-pm-debugging.txt
to see how deep you can get into the suspend
and have it still be reliable.
Comment 11 Alex Zhavnerchik 2010-02-02 13:42:41 UTC
Created attachment 24872 [details]
dmegs after fail on s2disk and s2ram

I tried to do s2ram last evening, but the system didn't slept and returned back, after that I tried to do s2disk, system waited for half of minute or so and then returned back again. After that I did dmesg which I'm attaching now
Comment 12 Alex Zhavnerchik 2010-02-03 22:56:17 UTC
Created attachment 24903 [details]
kernel log

I caught error on resume from s2ram

That is a kernel log where you can find stack trace and pointing to NULL pointer BUG in ttm, as I can understand.
Comment 13 Alex Zhavnerchik 2010-02-04 13:46:02 UTC
I forgot to mention that previous kernel log with NULL pointer bug I caught on 2.6.33-rc6 - so that is regression
Comment 14 Rafael J. Wysocki 2010-02-04 19:26:01 UTC
What's the last working kernel?
Comment 15 Alex Zhavnerchik 2010-02-04 22:16:25 UTC
Really I have never got working s2disk, before 2.6.33 I used nvidia blob
which never can resume from s2disk and I can't tell you does it work or
not.

On 2.6.33-rcX s2disk works sometimes, sometimes not. When I tested it as
described it kernel documentation - it worked all time, I tried it about 9
times with different debugging options and without them. But when I used
laptop for half of hour and then tried to do s2disk it hanged on suspending
after message "Suspending console" or something like this. One more note
about testing I tested immediately after loading in single user mode and
immediately after loading X server.

Last kernel log, with stack-trace and NULL pointer error, I got after resume
from s2ram.

On Thu, Feb 4, 2010 at 9:26 PM, <bugzilla-daemon@bugzilla.kernel.org> wrote:

> http://bugzilla.kernel.org/show_bug.cgi?id=15120
>
>
>
>
>
> --- Comment #14 from Rafael J. Wysocki <rjw@sisk.pl>  2010-02-04 19:26:01
> ---
> What's the last working kernel?
>
> --
> Configure bugmail: http://bugzilla.kernel.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You reported the bug.
>
Comment 16 Alex Zhavnerchik 2010-02-07 11:21:56 UTC
So, did last kernel log help you to fix a bug?
Comment 17 Rafael J. Wysocki 2010-02-07 11:32:10 UTC
Evidently, this is a nouveau driver bug, so reassigning.

Also, this is not a regression, because nouveau is new in 2.6.33-rc.
Comment 18 Alex Zhavnerchik 2010-02-09 09:48:57 UTC
So, did anybody from nouveau team notice this report?
Comment 19 Rafael J. Wysocki 2010-02-09 12:42:00 UTC
Switching to e-mail.

On Tuesday 09 February 2010, bugzilla-daemon@bugzilla.kernel.org wrote:
> http://bugzilla.kernel.org/show_bug.cgi?id=15120
> 
> --- Comment #18 from Alex Zhavnerchik <alex.vizor@gmail.com>  2010-02-09 09:48:57 ---
> So, did anybody from nouveau team notice this report?

Apparently not, so let's CC them.
Comment 20 Rafael J. Wysocki 2011-01-16 22:15:14 UTC
Is the problem still present in 2.6.37?
Comment 21 Alex Zhavnerchik 2011-01-17 08:58:16 UTC
Hi. Looks like it works with 2.6.37
Comment 22 Rafael J. Wysocki 2011-01-17 22:21:10 UTC
Cool, thanks!

Note You need to log in before you can comment on or make changes to this bug.