Bug 15117 - Crash in hrtimer code during halt
Crash in hrtimer code during halt
Status: RESOLVED CODE_FIX
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64
All Linux
: P1 normal
Assigned To: platform_x86_64@kernel-bugs.osdl.org
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-24 05:27 UTC by Aaron Barany
Modified: 2012-06-27 13:02 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32-5
Tree: Mainline
Regression: No


Attachments
A photograph of the stack backtrace after the segfault. (181.07 KB, image/jpeg)
2010-01-24 05:28 UTC, Aaron Barany
Details

Description Aaron Barany 2010-01-24 05:27:55 UTC
I recently updated to the latest kernel available in Debian testing (2.6.32-5), and whenever I shutdown my computer I get a segmentation fault when halt is called and the shutdown process never finishes. I can reboot without issues, but shutdown fails every time. If I boot in recovery mode and call halt immediately after logging in it still segfaults.

I have attached a photograph of the stack backtrace after it segfaults. I have also reported this with the Debian bugtracking system. (http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=566547) That has all the information about my system that was automatically gathered, as well as some discussion about the problem so far.
Comment 1 Aaron Barany 2010-01-24 05:28:55 UTC
Created attachment 24692 [details]
A photograph of the stack backtrace after the segfault.
Comment 2 Sven Joachim 2010-02-01 09:21:52 UTC
This appears to be a duplicate of bug 15005 which is fixed in 2.6.32.7.

Note You need to log in before you can comment on or make changes to this bug.