Bug 15108 - Blank screen with KMS enabled (on clevo M5xN laptop)
Blank screen with KMS enabled (on clevo M5xN laptop)
Status: CLOSED PATCH_ALREADY_AVAILABLE
Product: ACPI
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: Zhang Rui
:
Depends on:
Blocks: 14230
  Show dependency treegraph
 
Reported: 2010-01-22 20:30 UTC by Jérémy Lal
Modified: 2010-03-04 07:45 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: Yes


Attachments
dmidecode (9.02 KB, text/plain)
2010-01-22 20:31 UTC, Jérémy Lal
Details
clevo M550N acpidump (28.64 KB, application/gzip)
2010-01-26 09:13 UTC, Jérémy Lal
Details
patch: blacklist Clevo M5x0N for LVDS detection (706 bytes, patch)
2010-01-27 01:28 UTC, Zhang Rui
Details | Diff

Description Jérémy Lal 2010-01-22 20:30:39 UTC
Hi,
acpi lid status thinks it's closed when booting the laptop (every time).
- /proc/acpi/button/lid/LID/state is updated correctly when closing/opening
- it's the initial value given by acpi when powered on that is wrong
- no troubles on suspend/resume

So my workaround is to close/reopen it during before kernel loading.

I guess it could be eligible to the same fix as the one described in Bug 14957

dmidecode attached.

Regards.
Comment 1 Jérémy Lal 2010-01-22 20:31:21 UTC
Created attachment 24675 [details]
dmidecode
Comment 2 Zhang Rui 2010-01-26 08:16:14 UTC
no, this seems to be a different problem.
the laptops in that bug report can not report the correct lid state all the time.
please attach the acpidump of your laptop.
Comment 3 Jérémy Lal 2010-01-26 09:13:26 UTC
Created attachment 24713 [details]
clevo M550N acpidump
Comment 4 Zhang Rui 2010-01-27 01:28:40 UTC
Created attachment 24740 [details]
patch: blacklist Clevo M5x0N for LVDS detection

well, you're right.

The root cause of this problem is that BIOS reports incorrect(uninitialized) Lid state. I read the acpidump of your laptop and find that it's hard to fix the problem in Linux kernel, so we need the same solution as we do in bug #14957.

Patch attached. please give it a try.
Comment 5 Zhang Rui 2010-01-27 01:29:27 UTC
please re-open this bug if the patch in comment #4 doesn't work for you.
Comment 6 Rafael J. Wysocki 2010-02-05 22:29:24 UTC
Handled-By : Zhang Rui <rui.zhang@intel.com>
Patch : http://bugzilla.kernel.org/attachment.cgi?id=24740
Comment 7 Len Brown 2010-02-16 09:17:13 UTC
patch in comment #4 applied to acpi tree
Comment 8 Len Brown 2010-02-19 04:27:59 UTC
shipped in linux-2.6.33-rc8-git4
sent to linux-2.6l.32.stable

closed.
Comment 9 Jérémy Lal 2010-03-04 07:45:41 UTC
i confirm the patch is working on 2.6.33

Note You need to log in before you can comment on or make changes to this bug.