Bug 15107 - "Hardware is initialized using a guess method" with all 2.6.32 kernels
"Hardware is initialized using a guess method" with all 2.6.32 kernels
Status: RESOLVED INVALID
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA)
All Linux
: P1 normal
Assigned To: Jaroslav Kysela
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2010-01-22 19:23 UTC by Pacho Ramos
Modified: 2010-09-12 18:19 UTC (History)
2 users (show)

See Also:
Kernel Version:
Tree: Mainline
Regression: Yes


Attachments

Description Pacho Ramos 2010-01-22 19:23:46 UTC
I already reported this downstream:
http://bugs.gentoo.org/show_bug.cgi?id=299362

As you can see in the following link, gentoo-sources are really close to upstream:
http://sources.gentoo.org/viewcvs.py/linux-patches/genpatches-2.6/trunk/2.6.32/


Since update to kernel 2.6.32 I get the following when booting:
# /etc/init.d/alsasound restart
 * WARNING:  you are stopping a boot service.
 * Storing ALSA Mixer Levels ...                                               
                                                                       [ ok ]
 * Loading ALSA modules ...
 *   Loading: snd-card-0 ...                                                   
                                                                       [ ok ]
 *   Loading: snd-card-0 ...                                                   
                                                                       [ ok ]
 * Restoring Mixer Levels ...
Unknown hardware: "VIA8237" "Realtek ALC658D" "AC97a:414c4781" "0x147b"
"0x1415"
Hardware is initialized using a guess method
 * Errors while restoring defaults, ignoring                                   
                                                                       [ ok ]

My card is:
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237
AC97 Audio Controller (rev 60)

It works fine with 2.6.31, I hit the same error on 2.6.32 with alsa-utils-1.0.20 and 1.0.21

$ ls -l /usr/share/alsa/init/
total 36
-rw-r--r-- 1 root root  1808 dic 20 18:47 00main
-rw-r--r-- 1 root root  7271 dic 20 18:47 default
-rw-r--r-- 1 root root  1519 dic 20 18:47 hda
-rw-r--r-- 1 root root   391 dic 20 18:47 help
-rw-r--r-- 1 root root   932 dic 20 18:47 info
-rw-r--r-- 1 root root 10759 dic 20 18:47 test
$ grep VIA /usr/share/alsa/init/*
$

If you need more information, simply ask please :-)

Thanks a lot
Comment 1 Takashi Iwai 2010-01-25 13:20:48 UTC
This is no kernel error but just alsactl who spews it.
Comment 2 Pacho Ramos 2010-01-25 13:29:35 UTC
And, are you sure isn't it caused by some change on alsa-drivers included in kernel? alsactl reports no error with kernel 2.6.31 (and previous one)
Comment 3 Takashi Iwai 2010-01-25 13:53:23 UTC
The error in alsactl is irrelevant from the kernel change.
Comment 4 Pacho Ramos 2010-01-25 16:43:14 UTC
Then, why my hardware has became unrecognized since kernel update? (Unknown hardware: "VIA8237" "Realtek ALC658D" "AC97a:414c4781" "0x147b" "0x1415")

Thanks for the info :-)
Comment 5 Takashi Iwai 2010-01-25 16:47:18 UTC
alsactl tries to adapt the mixer changes, then it notices that the device doesn't need special quirks.  It's actually a mistake of alsactl which emits the error in that case.

Again, this is no kernel error.  It's an issue of alsactl.
Comment 6 Pacho Ramos 2010-01-25 16:59:17 UTC
OK, thanks a lot for the info, I will report it in the proper place then

Best regards

Note You need to log in before you can comment on or make changes to this bug.