Bug 15104 - SATA device doesn't come up after suspend to ram on Acer eMachines G725
Summary: SATA device doesn't come up after suspend to ram on Acer eMachines G725
Status: RESOLVED CODE_FIX
Alias: None
Product: IO/Storage
Classification: Unclassified
Component: Serial ATA (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Jeff Garzik
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-22 01:16 UTC by Jani-Matti Hätinen
Modified: 2010-01-28 06:52 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.32
Tree: Mainline
Regression: No


Attachments
dmesg output after resume (70.59 KB, application/octet-stream)
2010-01-22 01:16 UTC, Jani-Matti Hätinen
Details
lspci -vvnn output (22.69 KB, application/octet-stream)
2010-01-22 01:16 UTC, Jani-Matti Hätinen
Details
dmidecode output (11.09 KB, application/octet-stream)
2010-01-22 01:17 UTC, Jani-Matti Hätinen
Details
dmidecode output with BIOS version 3.04 (11.13 KB, application/octet-stream)
2010-01-22 04:11 UTC, Jani-Matti Hätinen
Details
acer-g725-broken-suspend.patch (850 bytes, patch)
2010-01-22 05:31 UTC, Tejun Heo
Details | Diff

Description Jani-Matti Hätinen 2010-01-22 01:16:05 UTC
Created attachment 24667 [details]
dmesg output after resume

On an Acer eMachines G725 notebook, with the latest Acer BIOS (v1.03) the SATA interface doesn't come up after resuming from suspend to ram.

Attached is the dmesg output from boot to after resume from suspend to ram. I added three line-breaks to signal the beginning of the suspend to ram & resume process.

All in all this looks fairly similar to bug #12276 the only problem being that Acer hasn't supplied a fixed BIOS yet (although obviously this could also be completely unrelated)

I'll also attach the outputs from dmidecode and lspci -vvnn
Comment 1 Jani-Matti Hätinen 2010-01-22 01:16:58 UTC
Created attachment 24668 [details]
lspci -vvnn output
Comment 2 Jani-Matti Hätinen 2010-01-22 01:17:38 UTC
Created attachment 24669 [details]
dmidecode output
Comment 3 Tejun Heo 2010-01-22 01:50:54 UTC
Yeah, it looks pretty much the same.  The problem is that we don't know how HP changed the BIOS there.  If we knew, we probably could implement it in the driver.  For now, I guess blacklisting is the only thing to do.  Have you contacted acer?

Thanks.
Comment 4 Jani-Matti Hätinen 2010-01-22 03:12:20 UTC
I was just planning to contact Acer about this and then decided to recheck their support site again. Turns out they've released a newer BIOS (v.3.04), which fixed this issue for me.

Sorry about the noise, although hopefully this report will be of use to someone struggling with the same issue.
Comment 5 Tejun Heo 2010-01-22 04:02:24 UTC
Can you please post dmidecode from the updated BIOS?  Let's blacklist the older ones.
Comment 6 Jani-Matti Hätinen 2010-01-22 04:11:44 UTC
Created attachment 24670 [details]
dmidecode output with BIOS version 3.04
Comment 7 Jani-Matti Hätinen 2010-01-22 04:20:10 UTC
Mind you, there are at least three BIOS versions between v1.03 and v3.04 (namely v1.06, v2.06 and v3.03) and I have absolutely no idea which one fixes the issue (as Acer doesn't seem to be interested in providing public changelogs).

However, all of these notebooks that I've seen (the number being 4) have been shipped with BIOS v1.03 or earlier, so as far as I've seen a BIOS update is probably necessary for the majority of owners anyway.
Comment 8 Tejun Heo 2010-01-22 05:31:04 UTC
Created attachment 24671 [details]
acer-g725-broken-suspend.patch

Can you please verify this patch?  Applied as-is, it shouldn't make any difference.  If you bump the .driver_data part to "V3.05", it should prevent suspend and warn about it.

Thanks.
Comment 9 Jani-Matti Hätinen 2010-01-27 22:58:41 UTC
Patch works as expected.

I'll try to get my hands on an unupdated G725 to test the unknown BIOS versions.
Comment 10 Tejun Heo 2010-01-28 06:52:03 UTC
Alright, forwarding patch upstream.  Please let me know further testing result.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.