Bug 15099 - ath5k does not see Atheros AR2427 hardware
Summary: ath5k does not see Atheros AR2427 hardware
Status: CLOSED DUPLICATE of bug 15180
Alias: None
Product: Drivers
Classification: Unclassified
Component: network-wireless (show other bugs)
Hardware: All Linux
: P1 high
Assignee: Luis Chamberlain
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-21 05:17 UTC by James Little
Modified: 2010-03-11 18:42 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.31-17-generic
Tree: Mainline
Regression: No


Attachments

Description James Little 2010-01-21 05:17:43 UTC
Also tested with kernel 2.6.31-14-generic, both under Ubuntu 9.10.
Hardware is the new Asus 1005PE netbook, but this Atheros chipset is not new.

Have successfully built the latest ath5k from the "bleeding edge" source and modprobe is ok. So the module is loaded but completely fails to see the hardware (same after reboot). There are no blacklisting issues. ifconfig/iwconfig etc. fail to find any devices. 

I believe this may be due to a new hardware location or vendor code. Here is the lspci output:

02:00.0 Network controller: Atheros Communications Inc. Device 002c (rev 01)

I have not seen 002c mentioned in relation to this chipset before (usually 168c I think). 

I have got the adapter working via ndiswrapper and a Windows XP driver. Without this, there doesn't seem to be any messages relating to the wireless adapter in dmesg or `lshw`.
Comment 1 Bob Copeland 2010-01-22 21:43:34 UTC
So, the 168c is the vendor id, 002c is the device id.  You should see both if you do lspci -vnn.

It seems to fall in the range of IDs assigned to ath9k though.  What happens if you add the appropriate stanza to ath_pci_id_table[] in drivers/net/wireless/ath/ath9k/pci.c ?
Comment 2 James Little 2010-01-23 08:44:32 UTC
Thanks for the tip Bob. 

As you suggested, I added the device id to ath_pci_id_table in ath9k/pci.c and recompiled. This time we do at least see that the hardware is probed (dmesg output): 

[  101.419504] ath9k 0000:02:00.0: enabling device (0000 -> 0002)
[  101.419527] ath9k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[  101.419553] ath9k 0000:02:00.0: setting latency timer to 64
[  101.419690] ath9k 0000:02:00.0: Failed to initialize device
[  101.419728] ath9k 0000:02:00.0: PCI INT A disabled
[  101.419750] ath9k: probe of 0000:02:00.0 failed with error -95


I thought that I should try a similar approach for the ath5k and so found the table ath5k_pci_id_table in ath5k/base.c. Again the hardware was probed, but unsuccessfully:

[  109.720483] ath5k 0000:02:00.0: enabling device (0000 -> 0002)
[  109.720505] ath5k 0000:02:00.0: PCI INT A -> GSI 17 (level, low) -> IRQ 17
[  109.720530] ath5k 0000:02:00.0: setting latency timer to 64
[  109.720612] ath5k 0000:02:00.0: registered as 'phy0'
[  109.722732] ath5k phy0: POST Failed !!!
[  109.722808] ath5k 0000:02:00.0: PCI INT A disabled
[  109.722845] ath5k: probe of 0000:02:00.0 failed with error -11

Here is the output of lspci -vnn:

02:00.0 Network controller [0280]: Atheros Communications Inc. Device [168c:002c] (rev 01)
	Subsystem: Device [1a3b:1112]
	Flags: fast devsel, IRQ 17
	Memory at f8000000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: [40] Power Management version 3
	Capabilities: [50] Message Signalled Interrupts: Mask- 64bit- Queue=0/0 Enable-
	Capabilities: [60] Express Legacy Endpoint, MSI 00
	Capabilities: [100] Advanced Error Reporting <?>
	Capabilities: [140] Virtual Channel <?>
	Capabilities: [160] Device Serial Number 12-14-24-ff-ff-17-15-00
	Capabilities: [170] Power Budgeting <?>
	Kernel modules: ath5k


You can see that the "Kernel driver in use" field is missing.
Comment 3 Bob Copeland 2010-02-09 15:34:52 UTC
(In reply to comment #2)
> Thanks for the tip Bob. 

> [  101.419750] ath9k: probe of 0000:02:00.0 failed with error -95

Hi,

Please try the patch here:

http://marc.info/?l=linux-wireless&m=126512991922435&w=2
Comment 4 Rolf Leggewie 2010-02-15 01:44:55 UTC
please resolve as a duplicate to bug 15180 from which that patch originates
Comment 5 John W. Linville 2010-03-03 16:56:34 UTC

*** This bug has been marked as a duplicate of bug 15180 ***

Note You need to log in before you can comment on or make changes to this bug.