Bug 15092 - support KAIREN's USB VGA adaptor
Summary: support KAIREN's USB VGA adaptor
Status: RESOLVED CODE_FIX
Alias: None
Product: Drivers
Classification: Unclassified
Component: USB (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: Greg Kroah-Hartman
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-20 08:52 UTC by Tanaka Akira
Modified: 2010-01-26 01:14 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc4
Tree: Mainline
Regression: No


Attachments
patch for USB20SVGA-MB-PLUS (419 bytes, patch)
2010-01-20 08:52 UTC, Tanaka Akira
Details | Diff

Description Tanaka Akira 2010-01-20 08:52:27 UTC
Created attachment 24659 [details]
patch for USB20SVGA-MB-PLUS

I found that KAIREN's USB VGA Adaptor (USB20SVGA-MB-PLUS) doesn't work.

It is because drivers/usb/misc/sisusbvga/sisusb.c doesn't
contain the product ID of the adaptor.

The vendor ID and the product ID is follows.

% lsusb
Bus 007 Device 002: ID 0711:0920 Magic Control Technology Corp.
...

The adaptor works with the attached patch.
I tested with Debian's kernel but it should be applicable to mainline.
Comment 1 Greg Kroah-Hartman 2010-01-20 14:43:10 UTC
On Wed, Jan 20, 2010 at 08:52:27AM +0000, bugzilla-daemon@bugzilla.kernel.org wrote:
> Created an attachment (id=24659)
>  --> (http://bugzilla.kernel.org/attachment.cgi?id=24659)
> patch for USB20SVGA-MB-PLUS

Please send the patch through email so that we can properly apply it as
described in the file, Documentation/SubmittingPatches.  We can't take
patches from bugzilla, sorry.
Comment 2 Andrew Morton 2010-01-26 01:14:24 UTC
Added sis-usb2vga-driver-support-kairens-usb-vga-adaptor-usb20svga-mb-plus.patch to -mm.

Note You need to log in before you can comment on or make changes to this bug.