Bug 15073 - BUG at kernel/time/clockevents.c:262 prevents computer from completely shutting down
BUG at kernel/time/clockevents.c:262 prevents computer from completely shutti...
Status: CLOSED DUPLICATE of bug 15037
Product: Timers
Classification: Unclassified
Component: Other
All Linux
: P1 normal
Assigned To: john stultz
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-01-16 19:21 UTC by Ozan Caglayan
Modified: 2010-01-23 12:15 UTC (History)
3 users (show)

See Also:
Kernel Version: 2.6.31.11
Tree: Mainline
Regression: Yes


Attachments
Screenshot of the stacktrace (688.94 KB, image/jpeg)
2010-01-17 09:00 UTC, Ozan Caglayan
Details
Screenshot of 2.6.32.3 stacktrace (785.16 KB, image/jpeg)
2010-01-17 10:30 UTC, Simon Munton
Details

Description Ozan Caglayan 2010-01-16 19:21:37 UTC
Hi,

One of our users reports that he can't properly shutdown the system and he gets a trace on VT.

The system is partly shutted down: The power led is off for example.

[4406.986777] kernel BUG at kernel/time/clockevents.c:262!
[4406.986777] invalid opcode: 0000 [#1] SMP
[4406.986777] last sysfs file: /sysfs/module/ip_tables/initstate


He only reported the first 3 lines, I'll try to make him write down the whole message ASAP.

I suspect the following commit which has been pushed to 2.6.31.10 which modifies kernel/time/clockevents.c:262.

From bb6eddf7676e1c1f3e637aa93c5224488d99036f Mon Sep 17 00:00:00 2001
From: Thomas Gleixner <tglx@linutronix.de>
Date: Thu, 10 Dec 2009 15:35:10 +0100
Subject: [PATCH] clockevents: Prevent clockevent_devices list corruption on cpu hotplug

CC'ing the author.
Comment 1 Ozan Caglayan 2010-01-17 09:00:51 UTC
Created attachment 24600 [details]
Screenshot of the stacktrace
Comment 2 Ozan Caglayan 2010-01-17 09:01:20 UTC
// Assign to Thomas Gleixner

Now I have 3 bug reports and 1 live system on which the bug appears. The 3 bug reporter have all Pentium 4 processors with different clock speeds.

I'm attaching a screenshot which will show the stacktrace.

Note that the commit was also introduced to 2.6.32.y with 2.6.32.3:
http://www.kernel.org/pub/linux/kernel/v2.6/ChangeLog-2.6.32.3

Thanks.
Comment 3 Ozan Caglayan 2010-01-17 09:02:15 UTC
The UI faked me, it seems to allow to change the assignee but once I submit it borks, sorry.
Comment 4 Simon Munton 2010-01-17 10:23:58 UTC
I am also getting this problem with kernel version 2.6.32.3. It doesn't always happen on poweroff, and every time I've enabled the serial console to try and capture the trace, the problem hasn't occurred.
I'll add a screenshot of the trace.
Comment 5 Simon Munton 2010-01-17 10:30:32 UTC
Created attachment 24602 [details]
Screenshot of 2.6.32.3 stacktrace

Screenshot of problem on 2.6.32.3 kernel
Comment 6 Ozan Caglayan 2010-01-17 15:17:41 UTC
Yes this is the same stacktrace. By the way reverting the commit I've mentioned above fixed the problem on 4 different systems all with Pentium 4 processors.
Comment 7 Ozan Caglayan 2010-01-18 07:19:44 UTC
// Marking this as a duplicate of 15037

*** This bug has been marked as a duplicate of bug 15037 ***

Note You need to log in before you can comment on or make changes to this bug.