Bug 150701 - Dell Venue 11 Pro 7140 tablet - power button, home button and folio cover can't wakeup from suspend freeze state, while wakeup via keyboard works
Summary: Dell Venue 11 Pro 7140 tablet - power button, home button and folio cover can...
Status: RESOLVED DUPLICATE of bug 102281
Alias: None
Product: Platform Specific/Hardware
Classification: Unclassified
Component: x86-64 (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: platform_x86_64@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-29 18:31 UTC by RussianNeuroMancer
Modified: 2016-08-15 07:21 UTC (History)
1 user (show)

See Also:
Kernel Version: 4.7.0
Tree: Mainline
Regression: No


Attachments
dmesg (58.13 KB, application/octet-stream)
2016-07-29 18:31 UTC, RussianNeuroMancer
Details

Description RussianNeuroMancer 2016-07-29 18:31:44 UTC
Created attachment 226871 [details]
dmesg

Dell Venue 11 Pro 7140 in pair with original Dell's folio cover have nice feature - tablet can detect when folio cover is closed and when folio cover is opened, so tablet can suspend automatically when user close cover, and wakeup automatically when user open cover.

For some reason this feature is working in Linux only with patches from bug 102281 (comment 50) but doesn't working with kernel without patches (4.4.0, 4.4.15, 4.7.0 was tested).

With patched kernel cover closing is detected as "lid close" event, and cover opening is detected as "wakeup button" event.

dmesg is attached. Please let me know what additional information I can provide to help fix this.
Comment 1 RussianNeuroMancer 2016-07-29 19:23:34 UTC
btw, I using "suspend freeze" mode. So when tablet get into suspend mode, for example Home button (sensor button with Windows logo below screen) is still react (with vibration) so kernel is not hang or something, it's still alive, that why I expect it to react on cover opening, and it's actually wakeup from this state if kernel is patched.
Comment 2 Zhang Rui 2016-08-08 13:41:28 UTC
Then this seems to be a duplicate of bug #102281, right?
Close as duplicate.

*** This bug has been marked as a duplicate of bug 102281 ***
Comment 3 RussianNeuroMancer 2016-08-08 13:46:07 UTC
> Then this seems to be a duplicate of bug #102281, right?

Not sure about this. Isn't this is completely different issues?
Comment 4 RussianNeuroMancer 2016-08-14 13:36:46 UTC
Yep, turns out to be really different.

I tested new intel-vbtn driver that solved bug #102281 but this particular issue with no wakeup from suspend freeze on folio opening remain unresolved.

By the way, intel-vbtn can't wakeup system on powerbutton press too. Wakeup by pressing buttons on keyboard works (but keyboard need to be attached which is in case of tablet useful only in docked state, not in tablet mode; not to mention that I doesn't have dock station at all, and I have to attach keyboard directly to USB port).
Comment 5 RussianNeuroMancer 2016-08-14 16:19:52 UTC
After reading https://bugzilla.kernel.org/show_bug.cgi?id=100171 I guess my symptoms is quite similar to what Helix 2 owners experience with suspend freeze - wakeup can be done only with keyboard, but not with lid or powerbutton. For some reason wakeup from suspend freeze works with dv11p-tablet driver https://bugzilla.kernel.org/show_bug.cgi?id=150701#c50
Comment 6 RussianNeuroMancer 2016-08-14 16:22:38 UTC
> but not with lid or powerbutton
I forget to mention Home button that is another way to wakeup tablet from Connected Standby in Windows. This way not works here too.
Comment 7 Zhang Rui 2016-08-15 06:37:25 UTC
(In reply to RussianNeuroMancer from comment #5)
> After reading https://bugzilla.kernel.org/show_bug.cgi?id=100171 I guess my
> symptoms is quite similar to what Helix 2 owners experience with suspend
> freeze - wakeup can be done only with keyboard, but not with lid or
> powerbutton. For some reason wakeup from suspend freeze works with
> dv11p-tablet driver https://bugzilla.kernel.org/show_bug.cgi?id=150701#c50
what's this link? there is no comment #50 in this bug report.

IMO, this is still a duplicate of 102281.
What you're experiencing is not a BUG, it is actually a feature missing for Dell systems, and the driver for this feature should be discussed in #102281.

*** This bug has been marked as a duplicate of bug 102281 ***
Comment 8 RussianNeuroMancer 2016-08-15 07:21:29 UTC
> what's this link?
Wrong link, sorry. Right one: https://bugzilla.kernel.org/show_bug.cgi?id=102281#c50

Note You need to log in before you can comment on or make changes to this bug.