Bug 150591 - broadwell-rt286 not working on Dell Venue 11 Pro 7140 since Linux 4.5.0rc1
Summary: broadwell-rt286 not working on Dell Venue 11 Pro 7140 since Linux 4.5.0rc1
Status: RESOLVED UNREPRODUCIBLE
Alias: None
Product: Drivers
Classification: Unclassified
Component: Sound(ALSA) (show other bugs)
Hardware: x86-64 Linux
: P1 normal
Assignee: Jaroslav Kysela
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2016-07-28 12:00 UTC by RussianNeuroMancer
Modified: 2019-10-03 17:18 UTC (History)
3 users (show)

See Also:
Kernel Version: 4.7.0
Tree: Mainline
Regression: No


Attachments
aplay -l output from kernel 4.4.15 (734 bytes, application/octet-stream)
2016-07-28 12:00 UTC, RussianNeuroMancer
Details
aplay -l output from kernel 4.5.0rc1 (356 bytes, application/octet-stream)
2016-07-28 12:01 UTC, RussianNeuroMancer
Details
list of audio cards on kernel 4.4.5 (201 bytes, application/octet-stream)
2016-07-28 12:01 UTC, RussianNeuroMancer
Details
list of audio cards on kernel 4.4.15 (201 bytes, application/octet-stream)
2016-07-28 12:01 UTC, RussianNeuroMancer
Details
list of audio cards on kernel 4.5.0rc1 (107 bytes, application/octet-stream)
2016-07-28 12:02 UTC, RussianNeuroMancer
Details
dmesg of kernel 4.4.15 (61.59 KB, application/octet-stream)
2016-07-28 12:02 UTC, RussianNeuroMancer
Details
dmesg of kernel 4.5.0rc1 (60.46 KB, application/octet-stream)
2016-07-28 12:02 UTC, RussianNeuroMancer
Details
sst acpi probing debug (1.62 KB, patch)
2016-08-16 03:15 UTC, Keyon
Details | Diff
dmesg of kernel 4.7.0 with sst acpi probing debug patch (56.36 KB, application/octet-stream)
2016-08-23 03:58 UTC, RussianNeuroMancer
Details
4.5.0 kernel config (187.72 KB, application/octet-stream)
2016-08-29 08:57 UTC, RussianNeuroMancer
Details

Description RussianNeuroMancer 2016-07-28 12:00:17 UTC
As you can see in attached "aplay -l", "cat /proc/asound/cards" and dmesg outputs, broadwell-rt286 is not initialize since Linux 4.5.0rc1. Issue is still present in 4.7.0 release. With Linux 4.4.15 playback to tablet speakers works fine.
Comment 1 RussianNeuroMancer 2016-07-28 12:00:51 UTC
Created attachment 226661 [details]
aplay -l output from kernel 4.4.15
Comment 2 RussianNeuroMancer 2016-07-28 12:01:10 UTC
Created attachment 226671 [details]
aplay -l output from kernel 4.5.0rc1
Comment 3 RussianNeuroMancer 2016-07-28 12:01:34 UTC
Created attachment 226681 [details]
list of audio cards on kernel 4.4.5
Comment 4 RussianNeuroMancer 2016-07-28 12:01:53 UTC
Created attachment 226691 [details]
list of audio cards on kernel 4.4.15
Comment 5 RussianNeuroMancer 2016-07-28 12:02:11 UTC
Created attachment 226701 [details]
list of audio cards on kernel 4.5.0rc1
Comment 6 RussianNeuroMancer 2016-07-28 12:02:28 UTC
Created attachment 226711 [details]
dmesg of kernel 4.4.15
Comment 7 RussianNeuroMancer 2016-07-28 12:02:41 UTC
Created attachment 226721 [details]
dmesg of kernel 4.5.0rc1
Comment 8 Keyon 2016-08-11 06:15:24 UTC
hi RussianNeuroMancer, can you check if there is INT343A in your folder: 
/sys/bus/acpi/devices/
Comment 9 RussianNeuroMancer 2016-08-11 14:49:03 UTC
Yes, it's there on 4.8.0rc1. aplay -l still show only HDMI outputs.
Comment 11 Keyon 2016-08-12 08:07:58 UTC
can you show the value of /sys/bus/acpi/devices/INT343A:00/status and /sys/bus/acpi/devices/INT3438:00/status ?
Comment 12 RussianNeuroMancer 2016-08-12 09:35:35 UTC
~# cat /sys/bus/acpi/devices/INT343A:00/status
15
~# cat /sys/bus/acpi/devices/INT3438:00/status
15
Comment 13 Keyon 2016-08-15 04:51:43 UTC
that looks correct. you may need add some log to trace the acpi probing.
Comment 14 RussianNeuroMancer 2016-08-15 05:53:57 UTC
Okay, please tell me what exactly I have to provide to help resolve this.
Comment 15 Keyon 2016-08-16 03:15:11 UTC
Created attachment 228991 [details]
sst acpi probing debug

hi, could you apply this patch and send back the dmesg?
Comment 16 RussianNeuroMancer 2016-08-23 03:58:26 UTC
Created attachment 229781 [details]
dmesg of kernel 4.7.0 with sst acpi probing debug patch

> hi, could you apply this patch and send back the dmesg?
New dmesg attached.
Comment 17 Keyon 2016-08-24 02:28:22 UTC
how about the output of 'lsmod | grep "snd"'?
Comment 18 RussianNeuroMancer 2016-08-24 03:59:04 UTC
While checking 'lsmod | grep "snd"' on latest kernel I find that issue no longer reproducible on Linux 4.8rc3 - audio is working now, so I guess this bugreport can be closed. If you still would like me to test Linux 4.5-4.7 kernels (provide logs/debug info) where audio doesn't work - please let me know.
Comment 19 Keyon 2016-08-24 07:54:49 UTC
I guess you didn't compile broadwell machine driver with 4.5~4.7 kernel, because we introduce a dw_core=y dependency at that stage.
latest 4.8rc3 fixed for takashi add a patch for that, iirc.

can you attach the kernel .config that you used to compile 4.5 kernel?

anyway, audio working for you is good news. :)
Comment 20 RussianNeuroMancer 2016-08-29 08:57:16 UTC
Created attachment 231111 [details]
4.5.0 kernel config

> I guess you didn't compile broadwell machine driver with 4.5~4.7 kernel
I installed this kernels: http://kernel.ubuntu.com/~kernel-ppa/mainline/

> because we introduce a dw_core=y dependency at that stage
My guess that was related, as you see in comment #10

> can you attach the kernel .config that you used to compile 4.5 kernel?
Ubuntu's Linux 4.5.0 kernel config attached.
Comment 21 szmaszmo 2019-07-28 18:23:10 UTC
As I already mention under https://bugzilla.kernel.org/show_bug.cgi?id=150601 since kernel 5.x (tested 5.2 on Manjaro) the card does not work  again??? (even speaker). Only some weird sounds come from the jack output.

Linux version 5.2.1-1-MANJARO (dmesg):
...
broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> System Pin mapping ok
broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload0 Pin mapping ok
broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Offload1 Pin mapping ok
broadwell-audio broadwell-audio: snd-soc-dummy-dai <-> Loopback Pin mapping ok
broadwell-audio broadwell-audio: rt286-aif1 <-> snd-soc-dummy-dai mapping ok
input: broadwell-rt286 Headset as /devices/pci0000:00/INT3438:00/broadwell-audio/sound/card1/input12
...
haswell-pcm-audio haswell-pcm-audio: Direct firmware load for intel/IntcPP01.bin failed with error -2
haswell-pcm-audio haswell-pcm-audio: error: message type 7 header 0x87000000
haswell-pcm-audio haswell-pcm-audio: error: reset stream 2 still running
haswell-pcm-audio haswell-pcm-audio: error: reset stream 0 still running
haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 failed
haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 failed
haswell-pcm-audio haswell-pcm-audio: ipc: error set dx state 3 failed
...
Comment 22 RussianNeuroMancer 2019-09-24 12:05:49 UTC
szmaszmo, issue appear between 5.2rc1 and 5.2rc2.
Comment 23 RussianNeuroMancer 2019-10-03 17:18:41 UTC
szmaszmo, there is new bugreport: bug 205083

Note You need to log in before you can comment on or make changes to this bug.