Bug 15045 - [i945] i915: *ERROR* Execbuf while wedged
Summary: [i945] i915: *ERROR* Execbuf while wedged
Status: RESOLVED DUPLICATE of bug 15004
Alias: None
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel) (show other bugs)
Hardware: All Linux
: P1 normal
Assignee: drivers_video-dri-intel@kernel-bugs.osdl.org
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2010-01-11 11:08 UTC by Johannes Engel
Modified: 2010-01-11 12:25 UTC (History)
2 users (show)

See Also:
Kernel Version: 2.6.32.3
Tree: Mainline
Regression: Yes


Attachments

Description Johannes Engel 2010-01-11 11:08:39 UTC
X Server lockups happen every now and then with the dmesg output:

[  614.220903] [drm:i915_gem_execbuffer] *ERROR* Execbuf while wedged
[  614.432038] [drm:i915_hangcheck_elapsed] *ERROR* Hangcheck timer elapsed... GPU hung
[  614.432058] render error detected, EIR: 0x00000000
[  614.432068] i915: Waking up sleeping processes
[  614.432125] reboot required

I can still move the mouse, switch to console works, but even restarting X leaves the screen black.
Manually "unwedging" does not help.
Referring to #14627, CONFIG_DMAR is disabled.

To me this seems to be related to Archlinux bug 17705: http://bugs.archlinux.org/task/17705

Hardware: intel 945GM
Comment 1 Colin Guthrie 2010-01-11 11:52:14 UTC
Probably a dupe of bug #15004 (but thanks for CC'ing me Johannes :))
Comment 2 Johannes Engel 2010-01-11 12:25:50 UTC
Thanks for the hint, Colin. As Tom did not comment in the other bug, I assumed there was none yet.

*** This bug has been marked as a duplicate of bug 15004 ***

Note You need to log in before you can comment on or make changes to this bug.