Bug 15043 - Display goes off with i915.powersave=1 after suspend-resume
Display goes off with i915.powersave=1 after suspend-resume
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: Jesse Barnes
:
: 15046 (view as bug list)
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-01-10 22:06 UTC by Rafael J. Wysocki
Modified: 2010-02-19 10:26 UTC (History)
5 users (show)

See Also:
Kernel Version: 2.6.32-rc3-git
Tree: Mainline
Regression: Yes


Attachments
vbios.dump (64.00 KB, application/octet-stream)
2010-01-30 15:16 UTC, Priit Laes
Details
Xorg.0.log (18.52 KB, text/plain)
2010-01-31 08:52 UTC, Priit Laes
Details
xrandr.log (5.07 KB, text/plain)
2010-01-31 08:53 UTC, Priit Laes
Details

Description Rafael J. Wysocki 2010-01-10 22:06:57 UTC
Subject    : 2.6.32-rc3-git display goes off with i915.powersave=1
Submitter  : Soeren Sonnenburg <sonne@debian.org>
Date       : 2010-01-10 20:09
References : http://marc.info/?l=linux-kernel&m=126315457519505&w=4

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-01-12 22:49:28 UTC
On Tuesday 12 January 2010, Soeren Sonnenburg wrote:
> On Sun, 2010-01-10 at 23:32 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15043
> > Subject		: Display goes off with i915.powersave=1
> > Submitter	: Soeren Sonnenburg <sonne@debian.org>
> > Date		: 2010-01-10 20:09 (1 days old)
> > References	: http://marc.info/?l=linux-kernel&m=126315457519505&w=4
> 
> I just recognized that only the *internal* display (i.e., LVDS1) goes
> dark while the external display VGA1 stays on. In addition there is some
> random screen flickering often before the display turns off...
Comment 2 ykzhao 2010-01-14 07:09:41 UTC
Will you please add the boot option of "drm.debug=0x06" on 2.6.33-rc3
kernel and attach the following output? (the i915 had better be compiled as
built-in kernel)
    a. dmesg
    b. xrandr -q --verbose
    c. Xorg.0.log
    d. the vbios.dump. The vbios.dump can be obtained by using the following
command
        1. echo 1 > /sys/devices/pci0000:00/0000:00:02.0/rom
        2. cat /sys/devices/pci0000:00/0000:00:02.0/rom >vbios.dump
        3. echo 0 > /sys/devices/pci0000:00/0000:00:02.0/rom


Thanks.
Comment 3 Priit Laes 2010-01-30 15:16:14 UTC
Created attachment 24793 [details]
vbios.dump

vbios dump from Lenovo X60s

Do you want these dmesg, xrandr and Xorg.0.log files after the display has gone blank?
Comment 4 Priit Laes 2010-01-30 15:24:06 UTC
The display only starts going off after the suspend-resume cycle. Before that things seem to be working fine.
Comment 5 Rafael J. Wysocki 2010-01-30 18:10:24 UTC
Ideally, please attach the logs for both the good and bad states.
Comment 6 Priit Laes 2010-01-31 08:23:49 UTC
I couldn't upload my kernel log (~200 mb unpacked / 6mb packed), so I uploaded it here:
http://plaes.org/files/2010-Q1/kernel.org.lzma

The display switch-off is now a bit harder to reproduce, but the display flickering and various corruptions still exists (but all this only happens after first suspend.)

I now have the full log-file from last boot and during that time there was only one switchoff which started around "Jan 31 01:48"

PS. There are bunch of bugs about the same issue on freedesktop.org (don't you guys communicate with xorg guys?)
https://bugs.freedesktop.org/show_bug.cgi?id=24928
Comment 7 Priit Laes 2010-01-31 08:52:42 UTC
Created attachment 24813 [details]
Xorg.0.log
Comment 8 Priit Laes 2010-01-31 08:53:58 UTC
Created attachment 24814 [details]
xrandr.log
Comment 9 Rafael J. Wysocki 2010-01-31 12:24:18 UTC
(In reply to comment #6)
> PS. There are bunch of bugs about the same issue on freedesktop.org (don't you
> guys communicate with xorg guys?)
> https://bugs.freedesktop.org/show_bug.cgi?id=24928

Generally, the people who work on the graphics use bugs.freedesktop.org, but the majority of kernel developers don't.
Comment 10 Rafael J. Wysocki 2010-02-04 20:41:33 UTC
On Thursday 04 February 2010, Soeren Sonnenburg wrote:
> On Mon, 2010-02-01 at 01:22 +0100, Rafael J. Wysocki wrote:
> > This message has been generated automatically as a part of a report
> > of recent regressions.
> > 
> > The following bug entry is on the current list of known regressions
> > from 2.6.32.  Please verify if it still should be listed and let me know
> > (either way).
> > 
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15043
> > Subject		: Display goes off with i915.powersave=1 after suspend-resume
> > Submitter	: Soeren Sonnenburg <sonne@debian.org>
> > Date		: 2010-01-10 20:09 (22 days old)
> > References	: http://marc.info/?l=linux-kernel&m=126315457519505&w=4
> 
> yes still exists in current git.
Comment 11 Alexander Lam 2010-02-04 23:51:10 UTC
This appears to be the same as bug #24314 on bugs.freedesktop.org: [945GME FBC] underruns followed by freeze after resume with FBC enabled
https://bugs.freedesktop.org/show_bug.cgi?id=24314
Comment 12 Jesse Barnes 2010-02-11 17:34:51 UTC
Fix pushed to for-linus:

commit	ee25df2bc379728c45d81e04cf87984db1425edf
drm/i915: handle FBC and self-refresh better

On 945, we need to avoid entering self-refresh if the compressor is
busy, or we may cause display FIFO underruns leading to ugly flicker.

Fixes fdo bug #24314, kernel bug #15043.
Comment 13 Marco Berizzi 2010-02-19 10:26:15 UTC
*** Bug 15046 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.