Bug 15038 - drm/ksm: fbdev blanking regression
drm/ksm: fbdev blanking regression
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 14885
  Show dependency treegraph
 
Reported: 2010-01-10 21:39 UTC by Rafael J. Wysocki
Modified: 2010-01-26 11:58 UTC (History)
0 users

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-10 21:39:54 UTC
Subject    : [bisected] drm/ksm: fbdev blanking regression in 2.6.33
Submitter  : Johan Hovold <jhovold@gmail.com>
Date       : 2010-01-06 17:00
References : http://marc.info/?l=linux-kernel&m=126279726418748&w=4
Handled-By : James Simmons <jsimmons@infradead.org>

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.

Bisected to:

commit 731b5a15a3b1474a41c2ca29b4c32b0f21bc852e
Author: James Simmons <jsimmons@infradead.org>
Date:   Thu Oct 29 20:39:07 2009 +0000

    drm/kms: properly handle fbdev blanking

    I examined several fbdev drivers and foudn the blanking code in
    drm_fb_helper to be wrong. This patch fixes the fbdev blanking to behave
    like other fbdev drivers.

    Signed-off-by: Dave Airlie <airlied@redhat.com>

First-Bad-Commit : 731b5a15a3b1474a41c2ca29b4c32b0f21bc852e

Note You need to log in before you can comment on or make changes to this bug.