Bug 15033 - drm: gem_object_free without struct_mutex
drm: gem_object_free without struct_mutex
Status: CLOSED CODE_FIX
Product: Drivers
Classification: Unclassified
Component: Video(DRI - Intel)
All Linux
: P1 normal
Assigned To: drivers_video-dri-intel@kernel-bugs.osdl.org
:
Depends on:
Blocks: 7216 14885
  Show dependency treegraph
 
Reported: 2010-01-10 21:06 UTC by Rafael J. Wysocki
Modified: 2010-01-11 23:49 UTC (History)
1 user (show)

See Also:
Kernel Version: 2.6.33-rc1
Tree: Mainline
Regression: Yes


Attachments

Description Rafael J. Wysocki 2010-01-10 21:06:45 UTC
Subject    : drm: gem_object_free without struct_mutex
Submitter  : Hugh Dickins <hugh.dickins@tiscali.co.uk>
Date       : 2009-12-30 19:45
References : http://marc.info/?l=linux-kernel&m=126220236201529&w=4
Handled-By : Jesse Barnes <jbarnes@virtuousgeek.org>

This entry is being used for tracking a regression from 2.6.32.  Please don't
close it until the problem is fixed in the mainline.
Comment 1 Rafael J. Wysocki 2010-01-11 23:48:03 UTC
On Tuesday 12 January 2010, Hugh Dickins wrote:
> On Sun, 10 Jan 2010, Rafael J. Wysocki wrote:
> > 
> > Bug-Entry	: http://bugzilla.kernel.org/show_bug.cgi?id=15033
> > Subject		: drm: gem_object_free without struct_mutex
> > Submitter	: Hugh Dickins <hugh.dickins@tiscali.co.uk>
> > Date		: 2009-12-30 19:45 (12 days old)
> > References	: http://marc.info/?l=linux-kernel&m=126220236201529&w=4
> > Handled-By	: Jesse Barnes <jbarnes@virtuousgeek.org>
> 
> Thanks, Rafael: please close it now.  I just checked latest -git
> and it is now fixed (but not fixed in 2.6.33-rc3) - thanks, Chris.

Note You need to log in before you can comment on or make changes to this bug.